AYIT-2020 609第十六周周赛 Harmonic Number (II)(数论)

I was trying to solve problem ‘1234 - Harmonic Number’, I wrote the following code

  long long H( int n ) {
 long long res = 0;
 for( int i = 1; i <= n; i++ )
     res = res + n / i;
 return res;
 } 

Yes, my error was that I was using the integer divisions only. However, you are given n, you have to find H(n) as in my code.
Input
Input starts with an integer T (≤ 1000), denoting the number of test cases.
Each case starts with a line containing an integer n (1 ≤ n < 231).
Output
For each case, print the case number and H(n) calculated by the code.
Sample Input
11
1
2
3
4
5
6
7
8
9
10
2147483647
Sample Output
Case 1: 1
Case 2: 3
Case 3: 5
Case 4: 8
Case 5: 10
Case 6: 14
Case 7: 16
Case 8: 20
Case 9: 23
Case 10: 27
Case 11: 46475828386

方法一 :
int t=sqrt(x);
公式sum=2(x/1+x/2+…+x/t)-t*t*

#include <stdio.h>
#include <string.h>
#include <math.h>
#include <algorithm>
#include <iostream>
using namespace std;
int main()
{
 int t;
 cin>>t;
 int kk=1;
 while(t--)
 {
  int x;
  cin>>x;
  long long sum=0;
  int m=(int)sqrt(x);
  for(int i=1;i<=m;i++)
  {
   sum+=x/i;
  }
  sum=sum*2-m*m;
  printf("Case %d: %lld\n",kk++,sum);
 }
}
/*
10
10/i 10 5 3 2 2 1 1 1 1 1  和27
m=3;
前三项sum=18;
sum*2=36;
m*m=9;
sum-m*m=27
*/

方法二:
先求出前sqrt(n)项和:即n/1+n/2+…+n/sqrt(n)
再求出后面所以项之和.后面每一项的值小于sqrt(n),计算值为1到sqrt(n)的项的个数,乘以其项值即可快速得到答案
例如:10/1+10/2+10/3+…+10/10
sqrt(10) = 3
先求出其前三项的和为10/1+10/2+10/3
在求出值为1的项的个数为(10/1-10/2)个,分别是(10/10,10/9,10/8,10/7,10/6),值为2个项的个数(10/2-10/3)分别是(10/5,10/4),在求出值为3即sqrt(10)的项的个数.
显然,值为sqrt(10)的项计算了2次,减去一次即可得到答案。当n/(int)sqrt(n) == (int)sqrt(n)时,值为sqrt(n)的值会被计算2次。

//题意和他说的那个公式一样求f(n)=n/1+n/2…n/n,但是呢超时是个问题,于是我们开始找规律,发现当j小于sqrt(n)的时候,按照暴力就可以,剩下的按照(n/j - n/(j+1)) * j这个累加就可以。

#include<stdio.h>
#include<math.h>
#include<string.h>
#include<algorithm>
using namespace std;
#include <iostream>
int main()
{
 int t;
 cin>>t;
 for(int i=1;i<=t;i++)
 {
  long long ans=0,x;
  cin>>x;
  int m=sqrt(x);
  for(int j=1;j<=m;j++)
  ans+=x/j;
  for(int j=1;j<=m;j++)
  ans+=(x/j-x/(j+1))*j;
  if(x/m==m)
  ans-=m;
   printf("Case %d: %lld\n",i,ans);
 }
}
  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值