杭电1229 还是A+B

还是A+B

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 18349    Accepted Submission(s): 8917


Problem Description
读入两个小于10000的正整数A和B,计算A+B。需要注意的是:如果A和B的末尾K(不超过8)位数字相同,请直接输出-1。
 

Input
测试输入包含若干测试用例,每个测试用例占一行,格式为"A B K",相邻两数字有一个空格间隔。当A和B同时为0时输入结束,相应的结果不要输出。
 

Output
对每个测试用例输出1行,即A+B的值或者是-1。
 

Sample Input
  
  
1 2 1 11 21 1 108 8 2 36 64 3 0 0 1
 

Sample Output
  
  
3 -1 -1 100
 

Source
 

Recommend
JGShining   |   We have carefully selected several similar problems for you:   1230  1237  1753  1555  1757 
 


...:

#include<stdio.h>
#include<string.h>
#include<math.h>
#include<algorithm>
using namespace std;
int n,m,j,k,l,i,a,b;
int main()
{
	while(scanf("%d%d%d",&a,&b,&k),a+b)
	{
		l=pow(10,k);
		if(a%l==b%l)
		printf("-1\n");
		else
		printf("%d\n",a+b);
	}
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值