poj3660 Cow Contest

Cow Contest
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 8967 Accepted: 5032

Description

N (1 ≤ N ≤ 100) cows, conveniently numbered 1..N, are participating in a programming contest. As we all know, some cows code better than others. Each cow has a certain constant skill rating that is unique among the competitors.

The contest is conducted in several head-to-head rounds, each between two cows. If cow A has a greater skill level than cow B (1 ≤ A ≤ N; 1 ≤ B ≤ NA ≠ B), then cow A will always beat cow B.

Farmer John is trying to rank the cows by skill level. Given a list the results of M (1 ≤ M ≤ 4,500) two-cow rounds, determine the number of cows whose ranks can be precisely determined from the results. It is guaranteed that the results of the rounds will not be contradictory.

Input

* Line 1: Two space-separated integers: N and M
* Lines 2..M+1: Each line contains two space-separated integers that describe the competitors and results (the first integer, A, is the winner) of a single round of competition: A and B

Output

* Line 1: A single integer representing the number of cows whose ranks can be determined
 

Sample Input

5 5
4 3
4 2
3 2
1 2
2 5

Sample Output

2

Source

floyd能过:

#include<stdio.h>
#include<string.h>
#include<algorithm>
#define N 0x3f3f3f3f
using namespace std;
int map[120][120],i,j,k,l,m,n,help,u,v;
void floyd()
{
	int i,j,k,l;
	for(i=1;i<=n;i++)
	for(j=1;j<=n;j++)
	{
		//if(map[i][j]==N)
		//continue;
		for(k=1;k<=n;k++)
		{
			if(map[j][i]+map[i][k]>1)//如果j能到达i并且i能到达k 
			map[j][k]=1;//那么j就能到达k 
		}
	}
}
int main()
{
	while(scanf("%d%d",&n,&m)!=EOF)
	{
		memset(map,0,sizeof(map));//先全部定义成0
		for(i=0;i<m;i++)
		{
			scanf("%d%d",&u,&v); 
			map[u][v]=1;//表示u能到达v 
		}
		floyd();
//		for(i=1;i<=n;i++)
//		{
//		for(j=1;j<=n;j++)
//		printf("%d %d\n",map[i][j],map[j][i]);
//		printf("****\n");
//	}
		int ans=0;
		for(i=1;i<=n;i++)
		{
			help=0;
			for(j=1;j<=n;j++)
			if(map[i][j]==1||map[j][i]==1)//计算当前这个点能到达的和能被到达的个数 
			help++;
			if(help==n-1)
			ans++;
		}
		printf("%d\n",ans);
	}
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值