POJ - 3660Cow Contest(Floyd表胜负关系)

LINK在这铁子
N (1 ≤ N ≤ 100) cows, conveniently numbered 1…N, are participating in a programming contest. As we all know, some cows code better than others. Each cow has a certain constant skill rating that is unique among the competitors.

The contest is conducted in several head-to-head rounds, each between two cows. If cow A has a greater skill level than cow B (1 ≤ A ≤ N; 1 ≤ B ≤ N; A ≠ B), then cow A will always beat cow B.

Farmer John is trying to rank the cows by skill level. Given a list the results of M (1 ≤ M ≤ 4,500) two-cow rounds, determine the number of cows whose ranks can be precisely determined from the results. It is guaranteed that the results of the rounds will not be contradictory.

Input

  • Line 1: Two space-separated integers: N and M
  • Lines 2…M+1: Each line contains two space-separated integers that describe the competitors and results (the first integer, A, is the winner) of a single round of competition: A and B

Output

  • Line 1: A single integer representing the number of cows whose ranks can be determined

Sample Input
5 5
4 3
4 2
3 2
1 2
2 5
Sample Output
2


  • 题意:n头牛m组数据,给出ab两个数,表示a赢了b。问可以推断出多少头牛的准确名次。
  • 分析:用二维数组表示胜负,然后Floyd(因为n小于等于100)推断更多的位次,最后循环遍历,找啊出哪头牛跟其他所有的牛都有关联。
  • ac代码:
#include<stdio.h>
int e[4510][4510];
int main()
{
	int n,m,i,j,k,t1,t2,ans,sum;
	scanf("%d%d",&n,&m);
	for(i=1;i<=n;i++)
	for(j=1;j<=n;j++)
	{
		if(i==j)
		e[i][j]=1;
		else e[i][j]=0;
	}
	while(m--)
	{
		scanf("%d%d",&t1,&t2);
		e[t1][t2]=1;//必须是单向的,表示i赢j 
	}
	for(k=1;k<=n;k++)//n<=100 
	for(i=1;i<=n;i++)
	for(j=1;j<=n;j++)
	{
		if(!e[i][j]&&e[i][k]&&e[k][j])
		{
			e[i][j]=1;
		}
	}
	sum=0;
	ans=0;
	for(i=1;i<=n;i++)
	{
		sum=0;
		for(j=1;j<=n;j++)
	{
		if(e[j][i]||e[i][j])
		sum++;
	}
		if(sum==n)
		ans++;
	}
	printf("%d\n",ans);	
} 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值