1059 Prime Factors (25分)

Given any positive integer N, you are supposed to find all of its prime factors, and write them in the format N = p​1​​​k​1​​​​×p​2​​​k​2​​​​×⋯×p​m​​​k​m​​​​.

Input Specification:

Each input file contains one test case which gives a positive integer N in the range of long int.

Output Specification:

Factor N in the format N = p​1​​^k​1​​*p​2​​^k​2​​**p​m​​^k​m​​, where p​i​​'s are prime factors of N in increasing order, and the exponent k​i​​ is the number of p​i​​ -- hence when there is only one p​i​​, k​i​​ is 1 and must NOT be printed out.

Sample Input:

97532468

Sample Output:

97532468=2^2*11*17*101*1291

题意:质因数分解,把一个大数分解成多个质数乘积,若一个数出现k次,那么就用这个质数的k次方表示。

#include<iostream>
#include<algorithm>
using namespace std;
int main(){

    int is_prime[40000];
    
    fill(is_prime, is_prime + 40000, 1);
    is_prime[0] = is_prime[1] = 0;
    for(int i = 2; i * i < 40000; i++){
        for(int j = 2; j * i < 40000; j++){
            is_prime[i * j] = 0;
        }
    }
    int n;
    scanf("%d", &n);
    printf("%d=", n);
    if(n == 1){
        printf("1\n");
        return 0;
    }
    for(int i = 2; n >1; i++){
        int cnt = 0;
        while (is_prime[i] && n % i == 0){
            cnt++;
            n = n / i;
            if(cnt == 1){
                printf("%d", i);
            }
        }
        if(cnt > 1){
            printf("^%d", cnt);
        }
        if(cnt && n > 1){
            printf("*");
        }
        

    }
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值