1059 Prime Factors (25 分)

Given any positive integer N, you are supposed to find all of its prime factors, and write them in the format N = p1​k1​×p2​k2​×⋯×pm​km​.

Input Specification:

Each input file contains one test case which gives a positive integer N in the range of long int.

Output Specification:

Factor N in the format N = p1​^k1​*p2​^k2​**pm​^km​, where pi​'s are prime factors of N in increasing order, and the exponent ki​ is the number of pi​ -- hence when there is only one pi​, ki​ is 1 and must NOT be printed out.

Sample Input:

97532468

Sample Output:

97532468=2^2*11*17*101*1291

 代码:

#include<iostream>
#include<cmath>
using namespace std;
struct factor
{
    int x,cnt;
}fac[10];
const int maxn=1000000;
bool prime[maxn]={false};
int p[maxn],count=0;
void find_prime()
{
    prime[1]=true;
    for(int i=2;i<maxn;i++)
        if(prime[i]==false)
        {
            p[count++]=i;
            for(int j=i+i;j<maxn;j+=i)
                prime[j]=true;
        }
}
int main()
{
    find_prime();
    int N,c=0;
    scanf("%d",&N);
    printf("%d=",N);
    if(N==1)
    {
        printf("1");
        return 0;
    }
    int M=sqrt(1.0*N);
    for(int i=0;i<M&&i<count;i++)
    {
        if(N%p[i]==0)
        {
            fac[c].x=p[i];
            fac[c].cnt=0;
            while(N%p[i]==0)
            {
                fac[c].cnt++;
                N/=p[i];
            }
            c++;
        }
    }
    if(N!=1)
    {
        fac[c].x=N;
        fac[c].cnt=1;
        c++;
    }
    for(int i=0;i<c;i++)
    {
        if(i!=0)
            printf("*");
        if(fac[i].cnt!=1)
            printf("%d^%d",fac[i].x,fac[i].cnt);
        else
            printf("%d",fac[i].x);
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值