Caocao's Bridges HDU - 4738(Tarjan求最小权值桥值)

Problem Description

Caocao was defeated by Zhuge Liang and Zhou Yu in the battle of Chibi. But he wouldn't give up. Caocao's army still was not good at water battles, so he came up with another idea. He built many islands in the Changjiang river, and based on those islands, Caocao's army could easily attack Zhou Yu's troop. Caocao also built bridges connecting islands. If all islands were connected by bridges, Caocao's army could be deployed very conveniently among those islands. Zhou Yu couldn't stand with that, so he wanted to destroy some Caocao's bridges so one or more islands would be seperated from other islands. But Zhou Yu had only one bomb which was left by Zhuge Liang, so he could only destroy one bridge. Zhou Yu must send someone carrying the bomb to destroy the bridge. There might be guards on bridges. The soldier number of the bombing team couldn't be less than the guard number of a bridge, or the mission would fail. Please figure out as least how many soldiers Zhou Yu have to sent to complete the island seperating mission.

Input

There are no more than 12 test cases.

In each test case:

The first line contains two integers, N and M, meaning that there are N islands and M bridges. All the islands are numbered from 1 to N. ( 2 <= N <= 1000, 0 < M <= N2 )

Next M lines describes M bridges. Each line contains three integers U,V and W, meaning that there is a bridge connecting island U and island V, and there are W guards on that bridge. ( U ≠ V and 0 <= W <= 10,000 )

The input ends with N = 0 and M = 0.

 

Output

For each test case, print the minimum soldier number Zhou Yu had to send to complete the mission. If Zhou Yu couldn't succeed any way, print -1 instead.

 

Sample Input

3 3 1 2 7 2 3 4 3 1 4 3 2 1 2 7 2 3 4 0 0

 

Sample Output

-1

4

 

Source

2013 ACM/ICPC Asia Regional Hangzhou Online

 

Tarjan求桥的最小权值,不过这道题的坑点较多。

派士兵炸桥,如果说桥上没有敌方士兵的时候,需要派出1个士兵炸桥(而不是0)。

如果说有几个连通图的时候,直接输出0就好了,因为就相当于桥已经被炸了。

#include<algorithm>
#include<iostream>
#include<map>
#include<cstring>
#include<vector>
using namespace std;
typedef long long ll;
const int maxn=1e3+100;
const int INF=0x3f3f3f3f;
int Instack[maxn],head[maxn],Belong[maxn];
int tot,scc;
int LOW[maxn],DFN[maxn],Stack[maxn],num[maxn];
int Index,top;
int bridge,tudeshuliang;
int putss[maxn],number=0;

void debug()
{
    cout<<"____I Love Acm!____"<<endl;
}
void debug_x(int x)
{
    cout<<"___mmp_"<<x<<endl;
}

struct Edge
{
    bool cut;
    int to,next,w;
} edge[maxn*maxn];

void addedge(int u,int v,int val)
{
    edge[tot].w=val;
    edge[tot].to=v;
    edge[tot].next=head[u];
    edge[tot].cut=false;
    head[u]=tot++;
}

void init()
{
    tot=0;
    number=0;
    tudeshuliang=0;
    memset(head,-1,sizeof(head));
}

void Tarjan(int u,int pre)
{
    int v;
    LOW[u]=DFN[u]=++Index;
    Stack[top++]=u;
    Instack[u]=true;
    int pre_cnt=0;
    for(int i=head[u];i!=-1; i=edge[i].next)
    {
        v=edge[i].to;
        if(v==pre&&pre_cnt==0) {pre_cnt++; continue;}
        if(!DFN[v])
        {
            Tarjan(v,u);
            if(LOW[u]>LOW[v]) LOW[u]=LOW[v];
            if(LOW[v]>DFN[u])
            {
                bridge++;
                putss[number++]=edge[i].w;
                edge[i].cut=true;
                edge[i^1].cut=true;
            }

        }
        else if(Instack[v]&&LOW[u]>DFN[v])
            LOW[u]=DFN[v];
    }
    if(LOW[u]==DFN[u])
    {
        scc++;
        do
        {
            v=Stack[--top];
            Instack[v]=false;
            Belong[v]=scc;
            num[scc]++;
        }while(v!=u);
    }

}

void solve(int N)
{
    memset(DFN,0,sizeof(DFN));
    memset(Instack,false,sizeof(Instack));
    memset(num,0,sizeof(num));
    bridge=scc=Index=top=0;
    for(int i=1;i<=N;++i)
        if(!DFN[i])
    {
        Tarjan(i,i);
        ++tudeshuliang;
    }
//    Tarjan(1,0);
    return ;
}

int main()
{
    int n,m;
    while(scanf("%d%d",&n,&m)&&n+m)
    {
        init();
        int u,v,w;
        for(int i=1; i<=m; ++i)
        {
            scanf("%d%d%d",&u,&v,&w);
            if(u==v) continue;
            addedge(u,v,w);
            addedge(v,u,w);

        }
        solve(n);//代表n个顶点,进行判断强连通分量的个数,求桥
        if(scc==1)
        {
            printf("-1\n");
        }
        else if(tudeshuliang>1)
        {
            printf("0\n");
        }
        else
        {
            int min_number=INF;
            for(int i=1;i<=n;++i)
            {
                for(int j=head[i];j!=-1;j=edge[j].next)
                {
                    if(edge[j].cut)
                    {
                        min_number=min(min_number,edge[j].w);
                    }
                }
            }
            if(min_number==INF)
            {
                printf("-1\n");
            }
            else if(min_number==0)
            {
                printf("1\n");
            }
            else
            {
                printf("%d\n",min_number);
            }
        }
    }
    return 0;
}

 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值