Caocao's Bridges HDU - 4738 边双联通无向图求桥

Caocao was defeated by Zhuge Liang and Zhou Yu in the battle of Chibi. But he wouldn't give up. Caocao's army still was not good at water battles, so he came up with another idea. He built many islands in the Changjiang river, and based on those islands, Caocao's army could easily attack Zhou Yu's troop. Caocao also built bridges connecting islands. If all islands were connected by bridges, Caocao's army could be deployed very conveniently among those islands. Zhou Yu couldn't stand with that, so he wanted to destroy some Caocao's bridges so one or more islands would be seperated from other islands. But Zhou Yu had only one bomb which was left by Zhuge Liang, so he could only destroy one bridge. Zhou Yu must send someone carrying the bomb to destroy the bridge. There might be guards on bridges. The soldier number of the bombing team couldn't be less than the guard number of a bridge, or the mission would fail. Please figure out as least how many soldiers Zhou Yu have to sent to complete the island seperating mission.
InputThere are no more than 12 test cases. 

In each test case: 

The first line contains two integers, N and M, meaning that there are N islands and M bridges. All the islands are numbered from 1 to N. ( 2 <= N <= 1000, 0 < M <= N  2

Next M lines describes M bridges. Each line contains three integers U,V and W, meaning that there is a bridge connecting island U and island V, and there are W guards on that bridge. ( U ≠ V and 0 <= W <= 10,000 ) 

The input ends with N = 0 and M = 0.OutputFor each test case, print the minimum soldier number Zhou Yu had to send to complete the mission. If Zhou Yu couldn't succeed any way, print -1 instead.Sample Input
3 3
1 2 7
2 3 4
3 1 4
3 2
1 2 7
2 3 4
0 0
Sample Output
-1

4

一个无向图,求出桥的最小值,注意三个坑点。

1,重边,注意判重

2.没有桥,输出-1

3 存在桥,但是权值为0,也要输出1,因为桥不可能自己炸断。

#include<bits/stdc++.h> 
#define inf 0x3f3f3f3f
using namespace std;
const int maxn=1010*1010;
int head[maxn];
int low[maxn],dfn[maxn],Stack[maxn];
bool instack[maxn];
int bridge[maxn];
int tot,cnt,num,_index,top,scc,_min;
struct node
{
	int to;
	int w;
	int id;
	int next;
}e[maxn*2];
void addedge(int u,int v,int id,int w)
{
	e[tot].to=v;
	e[tot].next=head[u];
	e[tot].w=w;
	e[tot].id=id;
	head[u]=tot++;
	return ;
}
void tarjan(int u,int pre)
{
	dfn[u]=low[u]=++_index;
	Stack[top++]=u;
	instack[u]=true;
	int v;
	for(int i=head[u];i!=-1;i=e[i].next)
	{
		v=e[i].to;
		if(e[i].id==pre)    //判重操作,目前还不理解,先记住吧 
		{
			continue;
		}
		if(dfn[v]==-1)
		{
			tarjan(v,e[i].id);
			low[u]=min(low[u],low[v]);
			if(low[v]>dfn[u])
			{
				bridge[++cnt]=e[i].w;
			}
		}
		else if(instack[v])
		{
			low[u]=min(low[u],dfn[v]);
		}
	}
	if(low[u]==dfn[u])
	{
		scc++;
		do
		{
			v=Stack[--top];
			instack[v]=false;
		}while(v!=u);
	}
	
} 
void solve(int n)
{
	int num=0;  
	for(int i=1;i<=n;i++)
	{
		if(dfn[i]==-1)
		{
			num++;
			tarjan(i,-1);
		} 
		if(num>1)   //不连通 代表走了多次 
		{
			break;
		}
	}
	if(num>1)
	{
		printf("0\n");
		return ;
	}
	if(cnt==0)  //如果没有桥,输出-1 
	{
		printf("-1\n");
		return ;
	}
	_min=inf;
	for(int i=1;i<=cnt;i++)
	{
		_min=min(bridge[i],_min);
	}
	if(_min!=0)
	{
		printf("%d\n",_min);
	}
	else   //如果权值为0,则输出1 
	{
		printf("%d\n",_min+1);
	}

}
int main()
{
#ifdef LOCAL
	freopen("C:/input.txt", "r", stdin);
#endif
	int n,m;
	int u,v,w;
	while(scanf("%d%d",&n,&m)==2)
	{
		if(!n&&!m)
		{
			break;
		}
		memset(head,-1,sizeof(head));
		memset(dfn,-1,sizeof(dfn));
		memset(low,0,sizeof(low));
		memset(Stack,0,sizeof(Stack));
		tot=cnt=_index=top=scc=0;
		for(int i=0;i<m;i++)
		{
			scanf("%d%d%d",&u,&v,&w);
			addedge(u,v,i,w);
			addedge(v,u,i,w);
		}
		solve(n);
	}
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值