A Simple Triangle

In this problem you need to make a triangle ,just like the sample out. The element in the ith row and jth column

should be the product(乘积) of i and j.

Input

The first line of input is an integer C which indicate the number of test cases. 
Then C test cases follow.Each test case contains an integer N (1<=N<=20) in a line which mentioned above.

Output

For each test case, print out the triangle. the triangle separated by a blank line. 
If the product is more than 9 (product > 9) you should print a space, or you should print two space.The final number of each line don't need print space. 

Sample Input

3
5
6
7

Sample Output

1  2  3  4  5
2  4  6  8
3  6  9
4  8
5

1  2  3  4  5  6
2  4  6  8  10
3  6  9  12
4  8  12
5  10
6

1  2  3  4  5  6  7
2  4  6  8  10 12
3  6  9  12 15
4  8  12 16
5  10 15
6  12
7

 

题意:给出一个数,输出相应的数据

题解:直接两层for循环就行了,关键就是在输出的时候要注意格式

           If the product is more than 9 (product > 9) you should print a space, or you should print two space

那么在输出的时候,要考虑三种情况:

1、是否为最后一个数据

2、是否大于9

3、是否小于9

#include<stdio.h>
#include<algorithm>
#include<cstring>
#include<cmath>
#include<vector>
#include<map>
#include<iostream>
using namespace std;

int main()
{
    int n;
    cin>>n;
    for(int kk=0;kk<n;++kk)
    {
        int num;
        cin>>num;
        for(int i=1;i<=num;++i)
        {
            for(int j=1;j<=num-i+1;++j)
            {
                if(j!=num-i+1)
                {
                    if(i*j<=9)
                        printf("%d  ",i*j);
                    else
                        printf("%d ",i*j);
                }
                else
                printf("%d",i*j);
            }
            printf("\n");
        }
        if(kk!=n-1)
        printf("\n");
    }
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值