poj 1753 Flip Game 搜索

Flip game is played on a rectangular 4x4 field with two-sided pieces placed on each of its 16 squares. One side of each piece is white and the other one is black and each piece is lying either it's black or white side up. Each round you flip 3 to 5 pieces, thus changing the color of their upper side from black to white and vice versa. The pieces to be flipped are chosen every round according to the following rules: 
  1. Choose any one of the 16 pieces. 
  2. Flip the chosen piece and also all adjacent pieces to the left, to the right, to the top, and to the bottom of the chosen piece (if there are any).

Consider the following position as an example: 

bwbw 
wwww 
bbwb 
bwwb 
Here "b" denotes pieces lying their black side up and "w" denotes pieces lying their white side up. If we choose to flip the 1st piece from the 3rd row (this choice is shown at the picture), then the field will become: 

bwbw 
bwww 
wwwb 
wwwb 
The goal of the game is to flip either all pieces white side up or all pieces black side up. You are to write a program that will search for the minimum number of rounds needed to achieve this goal. 

Input

The input consists of 4 lines with 4 characters "w" or "b" each that denote game field position.

Output

Write to the output file a single integer number - the minimum number of rounds needed to achieve the goal of the game from the given position. If the goal is initially achieved, then write 0. If it's impossible to achieve the goal, then write the word "Impossible" (without quotes).

Sample Input

bwwb
bbwb
bwwb
bwww

Sample Output

4


题意:给你一个4*4的方格,b代表黑色,w代表白色,每次可以反转一个格子使它变成相反的颜色,同时与它相邻的上下左右四个格子都变成相反的颜色,问最少需要反转几次可以使这个方格变成同一种颜色,如果不可能变成同一种颜色,就输出Impossible

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
char a[5][5];
int t[5][2]= {{1,0},{-1,0},{0,1},{0,-1},{0,0}};//上下左右及本身5个方向
int maxx;
int fun()  //判断这个4*4的方格是否为同一种颜色
{
    char c=a[0][0];
    int flag=0;
    for(int i=0; i<4; i++)
    {
        for(int j=0; j<4; j++)
        {
            if(a[i][j]!=c)
            {
                flag=1;
                break;
            }
        }
        if(flag==1)
            break;
    }
    if(flag==1)
        return 0;
    else
        return 1;
}
void turn(int x,int y) //反转,自己及周围四个小格子变换颜色
{

    for(int i=0; i<5; i++)
    {
        int tx=x+t[i][0];
        int ty=y+t[i][1];
        if(tx>=0&&tx<4&&ty>=0&&ty<4)
        {
            if(a[tx][ty]=='b')
                a[tx][ty]='w';
            else
                a[tx][ty]='b';
        }
    }
}
void dfs(int x,int y,int z)
{
    if(fun()) //如果格子颜色全部一样,找出最少的翻转次数
    {
        maxx=min(maxx,z); 
        return;
    }
    if(x==4)
        return;
    //每个格子都有反转不反转两种情况
    turn(x,y); //使这个格子反转
    if(y==3)
        dfs(x+1,0,z+1);
    else
        dfs(x,y+1,z+1);
        
    turn(x,y); //将反转的格子变回来,也就是不反转
    if(y==3)
        dfs(x+1,0,z);
    else
        dfs(x,y+1,z);

}

int main()
{
        for(int i=0; i<4; i++)
            scanf("%s",a[i]);
        maxx=999999;
        dfs(0,0,0);
        if(maxx==999999)
            printf("Impossible\n");
        else
            printf("%d\n",maxx);

    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值