poj 3414 Pots 搜索

Description

You are given two pots, having the volume of A and B liters respectively. The following operations can be performed:

  1. FILL(i)        fill the pot i (1 ≤ ≤ 2) from the tap;
  2. DROP(i)      empty the pot i to the drain;
  3. POUR(i,j)    pour from pot i to pot j; after this operation either the pot j is full (and there may be some water left in the pot i), or the pot iis empty (and all its contents have been moved to the pot j).

Write a program to find the shortest possible sequence of these operations that will yield exactly C liters of water in one of the pots.

Input

On the first and only line are the numbers AB, and C. These are all integers in the range from 1 to 100 and C≤max(A,B).

Output

The first line of the output must contain the length of the sequence of operations K. The following K lines must each describe one operation. If there are several sequences of minimal length, output any one of them. If the desired result can’t be achieved, the first and only line of the file must contain the word ‘impossible’.

Sample Input

3 5 4

Sample Output

6
FILL(2)
POUR(2,1)
DROP(1)
POUR(2,1)
FILL(2)

POUR(2,1)

题意:给出三个数,如n,m,s,其中n,m,分别为两个杯子的体积,开始杯子都为空,可以自由接水倒水,问这两个杯子需要几次操作可以使任意一个杯子中的水体积为s,输出次数和操作方法,如果杯子中水体积达不到s,输出impossible,总操作方法分为三种,FILL(a),将a杯子装满水,DROP(a),将a杯子水清空,POUR(a,b)将a杯子的水倒入b杯,倒满就停止

#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<map>
#include<queue>
#include<string>
#include<iostream>
using namespace std;

int n,m,s;
int flag;
struct p
{
    int x;
    int y;
    string str;
    friend bool operator<(p x,p y)
    {
        if(x.x==y.x)
            return x.y<y.y;
        return x.x<y.x;
    }
} tmp,now;

map<p,p>map1; //map一方面记录路径;一方面做标记,避免在队列中重复插入
void bfs()
{
    queue<p>Q;
    now.x=now.y=0;
    now.str="";
    tmp=now;
    map1[now]=tmp;
    Q.push(now);
    while(!Q.empty())
    {
        now=Q.front();
        Q.pop();
        if(now.x==s||now.y==s)
        {
            flag=1;
            return;
        }
        tmp.x=n;
        tmp.y=now.y;
        tmp.str="FILL(1)";
        if(map1.find(tmp)==map1.end())
        {
            Q.push(tmp);
            map1[tmp]=now;
        }

        tmp.x=now.x;
        tmp.y=m;
        tmp.str="FILL(2)";
        if(map1.find(tmp)==map1.end())
        {
            Q.push(tmp);
            map1[tmp]=now;
        }

        tmp.x=0;
        tmp.y=now.y;
        tmp.str="DROP(1)";
        if(map1.find(tmp)==map1.end())
        {
            Q.push(tmp);
            map1[tmp]=now;
        }

        tmp.x=now.x;
        tmp.y=0;
        tmp.str="DROP(2)";
        if(map1.find(tmp)==map1.end())
        {
            Q.push(tmp);
            map1[tmp]=now;
        }

        if(now.y>n-now.x)
        {
            tmp.x=n;
            tmp.y=now.y-(n-now.x);
        }
        else
        {
            tmp.x=now.y+now.x;
            tmp.y=0;
        }
        tmp.str="POUR(2,1)";
        if(map1.find(tmp)==map1.end())
        {
            Q.push(tmp);
            map1[tmp]=now;
        }

        if(now.x>m-now.y)
        {
            tmp.x=now.x-(m-now.y);
            tmp.y=m;
        }
        else
        {
            tmp.y=now.y+now.x;
            tmp.x=0;
        }
        tmp.str="POUR(1,2)";
        if(map1.find(tmp)==map1.end())
        {
            Q.push(tmp);
            map1[tmp]=now;
        }

    }
    return;
}
int main()
{
    while(~scanf("%d%d%d",&n,&m,&s))
    {
        flag=0;
        int sum=0;
        string ss="";
        bfs();
        if(flag==0)
            printf("impossible\n");
        else
        {
            for( tmp=now; tmp.x!=0||tmp.y!=0; tmp=map1[tmp])
            {
                ss=tmp.str+"\n"+ss;
                sum++;
            }
            printf("%d\n",sum);
            cout<<ss;
        }
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值