hdu 4115 Eliminate the Conflict 2-sat



Problem Description
Conflicts are everywhere in the world, from the young to the elderly, from families to countries. Conflicts cause quarrels, fights or even wars. How wonderful the world will be if all conflicts can be eliminated.
Edward contributes his lifetime to invent a 'Conflict Resolution Terminal' and he has finally succeeded. This magic item has the ability to eliminate all the conflicts. It works like this:
If any two people have conflict, they should simply put their hands into the 'Conflict Resolution Terminal' (which is simply a plastic tube). Then they play 'Rock, Paper and Scissors' in it. After they have decided what they will play, the tube should be opened and no one will have the chance to change. Finally, the winner have the right to rule and the loser should obey it. Conflict Eliminated!
But the game is not that fair, because people may be following some patterns when they play, and if the pattern is founded by others, the others will win definitely.
Alice and Bob always have conflicts with each other so they use the 'Conflict Resolution Terminal' a lot. Sadly for Bob, Alice found his pattern and can predict how Bob plays precisely. She is very kind that doesn't want to take advantage of that. So she tells Bob about it and they come up with a new way of eliminate the conflict:
They will play the 'Rock, Paper and Scissors' for N round. Bob will set up some restricts on Alice.
But the restrict can only be in the form of "you must play the same (or different) on the ith and jth rounds". If Alice loses in any round or break any of the rules she loses, otherwise she wins.
Will Alice have a chance to win?
 

Input
The first line contains an integer T(1 <= T <= 50), indicating the number of test cases.
Each test case contains several lines.
The first line contains two integers N,M(1 <= N <= 10000, 1 <= M <= 10000), representing how many round they will play and how many restricts are there for Alice.
The next line contains N integers B 1,B 2, ...,B N, where B i represents what item Bob will play in the i th round. 1 represents Rock, 2 represents Paper, 3 represents Scissors.
The following M lines each contains three integers A,B,K(1 <= A,B <= N,K = 0 or 1) represent a restrict for Alice. If K equals 0, Alice must play the same on A th and B th round. If K equals 1, she must play different items on Ath and Bthround.
 

Output
For each test case in the input, print one line: "Case #X: Y", where X is the test case number (starting with 1) and Y is "yes" or "no" represents whether Alice has a chance to win.
 

Sample Input
  
  
2 3 3 1 1 1 1 2 1 1 3 1 2 3 1 5 5 1 2 3 2 1 1 2 1 1 3 1 1 4 1 1 5 1 2 3 0
 

Sample Output
  
  
Case #1: no Case #2: yes
Hint
'Rock, Paper and Scissors' is a game which played by two person. They should play Rock, Paper or Scissors by their hands at the same time. Rock defeats scissors, scissors defeats paper and paper defeats rock. If two people play the same item, the game is tied..

题意:

两个人石头剪刀布,在知道一方出手的情况下,另一方是否能保证一局都不输,其中有m个限制条件,k=1时第u次和第v次出手必须不同,反之相同。


分析:

如果做过2-sat的题的话很容易看出。关键点在于建图,一次出手,只可能有两种情况(因为不能输)。而m个限制条件则可以转换成选取状态。

比如限定选取不同时:那么如果u1有可选a1、a2,u2可选b1、b2。 如果a1==b1  那么建边a1——>b2,b1——>a2。其余同理。

如果选定相同时:如果a1!=b1 那么建边a1——>b2,b1——>a2。其余同理。


#include <iostream>
#include<bits/stdc++.h>

using namespace std;
const int N=22000;
const int M=44000;
struct edge
{
    int to,next;
}edge[M];
int head[N],tot;
void init()
{
    tot=0;
    memset(head,-1,sizeof(head));
}

void addedge(int u,int v)
{
    edge[tot].to=v;edge[tot].next=head[u];head[u]=tot++;
}
int low[N],dfn[N],Stack[N],belong[N],Index,top,scc,instack[N],num[N];
void tarjan(int u)
{
    int v;
    low[u]=dfn[u]=++Index;
    Stack[top++]=u;
    instack[u]=1;
    for(int i=head[u];i+1;i=edge[i].next)
    {
        v=edge[i].to;
        if(!dfn[v])
        {
            tarjan(v);
            if(low[u]>low[v])   low[u]=low[v];
        }
        else if(instack[v]&&low[u]>dfn[v])
            low[u]=dfn[v];
    }
    if(low[u]==dfn[u])
    {
        scc++;
        do
        {
            v=Stack[--top];
            instack[v]=0;
            belong[v]=scc;
            num[scc]++;
        }
        while(v!=u);
    }
}

bool solvable(int n)
{
    memset(dfn,0,sizeof(dfn));
    memset(instack,0,sizeof(instack));
    memset(num,0,sizeof(num));
    Index=scc=top=0;
    for(int i=0;i<n;i++)
        if(!dfn[i])
            tarjan(i);
    for(int i=0;i<n;i+=2)
        if(belong[i]==belong[i^1])
            return 0;
    return 1;
}
int b[N];
int main()
{
    int T,kase=0,n,m,t;
    cin>>T;
    while(T--)
    {
        init();
        scanf("%d%d",&n,&m);
        for(int i=0;i<n;i++)
        {
            scanf("%d",&t);
            b[i*2]=--t;
            b[i*2+1]=(t+1)%3;
        }
        for(int i=0;i<m;i++)
        {
            int u1,u2,k;
            scanf("%d%d%d",&u1,&u2,&k);
            u1=u1*2-2;u2=u2*2-2;
            for(int ii=0;ii<=1;ii++)
                for(int jj=0;jj<=1;jj++)
                    if((b[u1^ii]!=b[u2^jj])^k)
                        addedge(u1^ii,u2^(1-jj)),addedge(u2^jj,u1^(1-ii));
        }
        if(solvable(2*n))   printf("Case #%d: yes\n",++kase);
        else    printf("Case #%d: no\n",++kase);
    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值