2017 ACM/ICPC Asia Regional Qingdao Online 1007 hdu 6212 Zuma 区间dp



Problem Description
Think about the Zuma Game. You have a row of at most  200  black(0) or white(1) balls on the table at the start. Each three consecutive balls never share the same colour. You also have infinite amount of black and white balls in your hand. On each turn, you can choose a ball in your hand and insert it into the row, including the leftmost place and the rightmost place. Then, if there is a group of three of more balls in the same colour touching, remove these balls. Keep doing this until no more balls can be removed.
Find the minimal balls you have to insert to remove all the balls on the table.
 

Input
The first line of input contains an integer  T (1T100)  which is the total number of test cases.
Each test case contains a line with a non-empty string of  0  and  1  describing the row of balls at the start.
 

Output
For each test case, output the case number and the minimal balls required to insert in a line.
 

Sample Input
  
  
4 10101 101001001 1001001001 01001101011001100
 

Sample Output
  
  
Case #1: 4 Case #2: 3 Case #3: 3 Case #4: 2
 


题意:

给你一串01串,你可以在任意位置插入0或1,有三个及以上的连续的相同的会消去,会有连锁反应,问至少插几次能消完


思路:听说是个原题,,,这场真多原题

有三种消除方式:

1.直接将区间分成两部分,各消各的。

2.如果两头是同色的,可以消完中间的,合并后消去两头,代价和两头的数量有关。

3.如果两头同色,又存在一头只有一个连续的情况,可以中间再找一个相同颜色的,三个合并后再消。



//
//  main.cpp
//  1007
//
//  Created by zc on 2017/9/18.
//  Copyright © 2017年 1004. All rights reserved.
//

#include <iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<algorithm>
using namespace std;
const int N=220;
char s[N];
int a[N],f[N][N];

int main(int argc, const char * argv[]) {
    int T,kase=0;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%s",s);
        int n=strlen(s),m=0;
        a[++m]=1;
        for(int i=1;i<n;i++)
        {
            if(s[i]!=s[i-1])    a[++m]=0;
            a[m]++;
        }
        for(int i=m;i>0;i--)
            for(int j=i;j<=m;j++)
            {
                if(i==j)//i==j 直接返回需要补充的数量
                {
                    f[i][j]=3-a[i];
                    continue;
                }
                f[i][j]=n+n;//初始化最大值为2*n
                for(int k=i;k<j;k++)    f[i][j]=min(f[i][j],f[i][k]+f[k+1][j]);//分成两半考虑
                if((j-i)&1) continue;//如果间隔为奇数,则不是同种颜色
                f[i][j]=min(f[i][j],f[i+1][j-1]+(a[i]+a[j]==2));//i和j同色,可以等中间消掉,如果两边都是1还得加上1的代价
                if(a[i]+a[j]<4)//如果i和j存在有1,可以i,k,j三个同色的一起消
                {
                    for(int k=i+2;k<j;k+=2)
                        if(a[k]==1) f[i][j]=min(f[i][j],f[i+1][k-1]+f[k+1][j-1]);
                }
            }
        printf("Case #%d: %d\n",++kase,f[1][m]);
    }
}


  • 3
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 10
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 10
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值