Ride to School

Ride to School
Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 19961 Accepted: 8048

Description

Many graduate students of Peking University are living in Wanliu Campus, which is 4.5 kilometers from the main campus – Yanyuan. Students in Wanliu have to either take a bus or ride a bike to go to school. Due to the bad traffic in Beijing, many students choose to ride a bike. 

We may assume that all the students except "Charley" ride from Wanliu to Yanyuan at a fixed speed. Charley is a student with a different riding habit – he always tries to follow another rider to avoid riding alone. When Charley gets to the gate of Wanliu, he will look for someone who is setting off to Yanyuan. If he finds someone, he will follow that rider, or if not, he will wait for someone to follow. On the way from Wanliu to Yanyuan, at any time if a faster student surpassed Charley, he will leave the rider he is following and speed up to follow the faster one. 

We assume the time that Charley gets to the gate of Wanliu is zero. Given the set off time and speed of the other students, your task is to give the time when Charley arrives at Yanyuan. 

Input

There are several test cases. The first line of each case is N (1 <= N <= 10000) representing the number of riders (excluding Charley). N = 0 ends the input. The following N lines are information of N different riders, in such format: 

Vi [TAB] Ti 

Vi is a positive integer <= 40, indicating the speed of the i-th rider (kph, kilometers per hour). Ti is the set off time of the i-th rider, which is an integer and counted in seconds. In any case it is assured that there always exists a nonnegative Ti. 

Output

Output one line for each case: the arrival time of Charley. Round up (ceiling) the value when dealing with a fraction.

Sample Input

4
20	0
25	-155
27	190
30	240
2
21	0
22	34
0

Sample Output

780
771
 
分析:
1.时间为负的不用管,直接去掉,因为如果你可以追上他(A),那么说明你的速度比他快,那么你不会去跟着他(A)走,如果追不上,那就更加不用说。
2.找一个到达时间最少的,输出这个答案就行了,因为用时最少那么他一定会追上你,你一定会最后跟着他走,他到达的时间也就是你到达的最少时间了(t=s/v+t0)
3.精度问题,比如得到1.1,你就应该输出2,那么就是if(aa-(int)aa>0.0)
源代码:
#include <iostream>
#include <climits>
#include <algorithm>
using namespace std;
int main()
{
	int i,n,v,t,ans=INT_MAX;
	double tmp;
	while(cin>>n && n)
	{
		while(n--)
		{
			cin>>v>>t;
			if(t>=0)
			{
				tmp=4.5*3600/v;
				if(tmp-(int)tmp>0.0)
				  tmp++;
				tmp+=t;
				if(ans>tmp)
				{
					ans=tmp;
				}
			}
		}
		cout<<ans<<endl;
		ans=INT_MAX;
	}
	return 0;
}
 
 


                
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值