hdu2055

An easy problem

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 18849    Accepted Submission(s): 12585


Problem Description
we define f(A) = 1, f(a) = -1, f(B) = 2, f(b) = -2, ... f(Z) = 26, f(z) = -26;
Give you a letter x and a number y , you should output the result of y+f(x).
 

Input
On the first line, contains a number T.then T lines follow, each line is a case.each case contains a letter and a number.
 

Output
for each case, you should the result of y+f(x) on a line.
 

Sample Input
  
  
6 R 1 P 2 G 3 r 1 p 2 g 3
 

Sample Output
  
  
19 18 10 -17 -14 -4
 


遇到的问题和思路:

       我还以为和杭电的2054的题目一样是大数据呢,没想到是水题。。。不过个人感觉杭电的2054的题目有点问题啊,看到discuss里面以后,我用两个人AC的代码测试了两个不同的数据,一个输出是YES 一个是NO,但是竟然都AC了。


给出代码:


#include<cstdio>
#include<algorithm>
#include<cmath>
#include<cstring>
#define inf 1e-12


using namespace std;


int f[30];
char a;
int b;


int main(){
int t,indexx;
for(int i = 0;i < 29;i++)f[i] = i;
scanf("%d",&t);
getchar();
while(t--){
scanf("%c%d",&a,&b);
getchar();
if(a>='a'&&a<='z'){
indexx = a - 'a' + 1;
indexx*=-1;
}
else {
indexx = a - 'A' + 1;
}
printf("%d\n",indexx + b);
}
return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值