HDUOJ 2055 An easy problem

HDUOJ 2055 An easy problem


Problem Description
we define f(A) = 1, f(a) = -1, f(B) = 2, f(b) = -2, … f(Z) = 26, f(z) = -26;
Give you a letter x and a number y , you should output the result of y+f(x).

Input
On the first line, contains a number T.then T lines follow, each line is a case.each case contains a letter and a number.

Output
for each case, you should the result of y+f(x) on a line.

Sample Input
6
R 1
P 2
G 3
r 1
p 2
g 3

Sample Output
19
18
10
-17
-14
-4

刚开始想复杂了,还用到字符数组来计算,有点麻烦了,后来简化了下不知道为什么输出格式也有问题,参考了一个大佬的代码用函数判断大小写字母就没问题了

#include<stdio.h>
#include<ctype.h>
int main()
{
	int n;
	scanf("%d%*c",&n);   //%*c和getchar();功能差不多
	//getchar();
	while(n--)
	{
		int m;
		char x;
		scanf("%c%d%*c",&x,&m);
		//getchar();
		if(isupper(x))//如果是大写字母
			printf("%d\n",x-'A'+1+m);
		else
			printf("%d\n",'a'-x-1+m);
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值