POJ 2386 深度搜索

Lake Counting
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 26109 Accepted: 13115

Description

Due to recent rains, water has pooled in various places in Farmer John's field, which is represented by a rectangle of N x M (1 <= N <= 100; 1 <= M <= 100) squares. Each square contains either water ('W') or dry land ('.'). Farmer John would like to figure out how many ponds have formed in his field. A pond is a connected set of squares with water in them, where a square is considered adjacent to all eight of its neighbors. 

Given a diagram of Farmer John's field, determine how many ponds he has.

Input

* Line 1: Two space-separated integers: N and M 

* Lines 2..N+1: M characters per line representing one row of Farmer John's field. Each character is either 'W' or '.'. The characters do not have spaces between them.

Output

* Line 1: The number of ponds in Farmer John's field.

Sample Input

10 12
W........WW.
.WWW.....WWW
....WW...WW.
.........WW.
.........W..
..W......W..
.W.W.....WW.
W.W.W.....W.
.W.W......W.
..W.......W.

Sample Output

3

遇到的问题和思路:

       这道题目也是书上的例题。我记得我最初看到这道题目的时候,首先是题目没有看懂,不知道什么叫8面连同,在后来看了题目的代码以后才明白是是要遍历周围的8个方位才对。

       还有一点就是一定要注意全部都遍历,在dfs中一定要注意这一点,不能忘了。


给出代码:


#include<cstdio>
#include<cmath>
#include<algorithm>
#include<cstring>

using namespace std;

int n , m;
char map[105][105];
int ans;
int nx , ny;

void dfs(int x,int y){
	for(int i = -1; i <= 1; i++){
		for(int j = -1; j <= 1; j++){
			nx = x + i,ny = y + j;
			if(nx >= 0 && nx < n && ny >= 0 && ny <=m && map[nx][ny] == 'W'){
				map[nx][ny] = '.';
				dfs(nx , ny);
			}
		}
	}
	
	
}


void solve(){
	ans = 0;
	for(int i = 0; i < n; i++){
		for(int j = 0;j < m; j++){
			if(map[i][j] == 'W'){
				dfs(i , j);
				ans++;
			}
		}
	}
	printf("%d\n",ans);
}

int main(){
	while(scanf("%d%d",&n,&m)!=EOF){
		memset(map , 0 ,sizeof(map));
		for(int i = 0; i < n ; i++){
		    getchar();	
		    for(int j = 0; j < m ; j++)
		        scanf("%c",&map[i][j]);
		}
		solve();
	}
	return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值