POJ-2002-Squares

Squares
Time Limit: 3500MS Memory Limit: 65536K
Total Submissions: 18718 Accepted: 7209

Description

A square is a 4-sided  polygon (多边形) whose sides have equal length and  adjacent (邻近的) sides form 90-degree angles. It is also a polygon such that  rotating (旋转的) about its centre by 90 degrees gives the same polygon. It is not the only polygon with the latter property, however, as a regular  octagon (八边形) also has this property. 

So we all know what a square looks like, but can we find all possible squares that can be formed from a set of stars in a night sky? To make the problem easier, we will  assume (承担) that the night sky is a 2-dimensional plane, and each star is  specified (指定) by its x and y  coordinates (坐标)

Input

The  input (投入) consists of a number of test cases. Each test case starts with the  integer (整数) n (1 <= n <= 1000)  indicating (表明) the number of points to follow. Each of the next n lines specify the x and y coordinates (two integers) of each point. You may assume that the points are  distinct (明显的) and the  magnitudes (大小) of the coordinates are less than 20000. The input is  terminated (终止) when n = 0.

Output

For each test case, print on a line the number of squares one can form from the given stars.

Sample Input

4
1 0
0 1
1 1
0 0
9
0 0
1 0
2 0
0 2
1 2
2 2
0 1
1 1
2 1
4
-2 5
3 7
0 0
5 2
0

Sample Output

1
6
1

已知正方形两点(x1,y1), (x2,y2)
x3 = x1-(y1-y2);
y3 = y1+(x1-x2);
x4 = x2-(y1-y2);
y4 = y2+(x1-x2);

x3 = x1+(y1-y2);
y3 = y1-(x1-x2);
x4 = x2+(y1-y2);
y4 = y2-(x1-x2);  

#include<iostream>
#include<string.h>
#include<stdio.h>
#include<math.h>
#include<algorithm>
#include<queue>
#include<vector>
using namespace std;
const int mod = 100007;
struct node
{
    int x, y;
}xt[1001];
int n;
node * hash[mod+5];
void add(int x, int y)
{
    int key = (x*x+y*y)%mod+1;
    if(!hash[key])
    {
        node *p = new node;
        p->x=x;
        p->y=y;
        hash[key] = p;
    }
    else
    {
        while(hash[key])++key;
        node *p = new node;
        p->x=x;
        p->y=y;
        hash[key] = p;
    }
}
bool Find(int x, int y)
{
    int key = (x*x+y*y)%mod+1;
    if(hash[key])
    {
        while(hash[key])
        {
            if(hash[key]->x==x&&hash[key]->y==y)return true;
            key++;
        }
    }
        return false;
}
int main()
{
    int x3,y3,x4,y4,x1,x2,y1,y2;
    while(~scanf("%d", &n)&&n)
    {
        memset(hash, 0, sizeof(hash));
        for(int i = 0;i<n;++i)
        {
            scanf("%d%d",&xt[i].x, &xt[i].y);
            add(xt[i].x, xt[i].y);
        }
        int cnt = 1;
        for(int i = 0;i<n-1;++i)
        {
            x1 = xt[i].x, y1 = xt[i].y;
            for(int j = i+1; j<n;++j)
            {
                x2 = xt[j].x, y2 = xt[j].y;

                x3 = x1-(y1-y2);
                y3 = y1+(x1-x2);
                x4 = x2-(y1-y2);
                y4 = y2+(x1-x2);
                if(Find(x3,y3)&&Find(x4, y4))
                    cnt++;

                x3 = x1+(y1-y2);
                y3 = y1-(x1-x2);
                x4 = x2+(y1-y2);
                y4 = y2-(x1-x2);
                if(Find(x3,y3)&&Find(x4, y4))
                    cnt++;

            }
        }
        printf("%d\n", cnt/4);
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值