[AIZU ONLINE JUDGE] 计算几何 CGL_3_B (判断凸多边形)

Is-Convex

For a given polygon g, print "1" if g is a convex polygon, "0" otherwise. Here, in a convex polygon, all interior angles are less than or equal to 180 degrees.

g is represented by a sequence of points p1, p2,..., pn where line segments connecting pi and pi+1 (1 ≤ i ≤ n−1) are sides of the polygon. The line segment connecting pn and p1 is also a side of the polygon.

Input

g is given by coordinates of the points p1,..., pn in the following format:

n
x1 y1 
x2 y2
:
xn yn

The first integer n is the number of points. The coordinate of a point pi is given by two integers xi and yi. The coordinates of points are given in the order of counter-clockwise visit of them.

Output

Print "1" or "0" in a line.

Constraints

  • 3 ≤ n ≤ 100
  • -10000 ≤ xiyi ≤ 10000
  • No point of the polygon will occur more than once.
  • Two sides of the polygon can intersect only at a common endpoint.

Sample Input 1

4
0 0
3 1
2 3
0 3

Sample Output 1

1

Sample Input 2

5
0 0
2 0 
1 1
2 2
0 2

Sample Output 2

0

题目大意:逆时针给定n个点,判断这n个点组成的多边形是否是凸多边形,如果是则输出1,否则输出0;

题解:

对于一个多边形,从逆时针的方向来讲,相邻的三个点所组成的有向面积应该是大于0的,即

Point[3] 一定是在 Point[1], Point[2] 组成直线的“左”边,有向面积大于0(其实就是叉乘) 

附下模板:

#include<iostream>
#include<algorithm>
#include<cstring>
#include<cmath>

using namespace std;

const int N = 110;
const double eps = 1e-10;

int sign(double x)  //计算几何中用来判断符号正负或等于0的函数
{
	if (fabs(x) <= eps)return 0;
	if (x > 0) return 1;
	return -1;
}

struct Point
{
	double x, y;

	Point(double x = 0, double y = 0) : x(x), y(y) { }
	Point operator -(const Point& t) { return Point(x - t.x, y - t.y); }
};

typedef Point Vector;
Point p[N];
int n;

double cross(Point A, Point B)
{
	return A.x * B.y - A.y * B.x;
};

double _area(Point A, Point B, Point C)  //有向面积 用于判断两向量的夹角是正还是负
{
	return cross(B - A, C - A);
}

bool is_convex(Point p[], int n)
{
    // 枚举多边形所有的点,如果存在两向量有向面积为负,则证明多边形存在凹陷 直接返回false
	for (int i = 0; i + 1 < n; i++)
		if (sign(_area(p[i], p[i + 1], p[i + 2])) < 0) return false;

	return true;
}

int main()
{
	cin >> n;
	for (int i = 0; i < n; i++)
		cin >> p[i].x >> p[i].y;

	if (is_convex(p, n)) cout << 1 << endl;
	else cout << 0 << endl;

	return 0;
}

这题好有意思,如果直接输出 bool 类型的 0, 1 居然会提示格式错误

  • 0
    点赞
  • 19
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值