PAT 甲级 1037. Magic Coupon (25)

The magic shop in Mars is offering some magic coupons. Each coupon has an integer N printed on it, meaning that when you use this coupon with a product, you may get N times the value of that product back! What is more, the shop also offers some bonus product for free. However, if you apply a coupon with a positive N to this bonus product, you will have to pay the shop N times the value of the bonus product... but hey, magically, they have some coupons with negative N's!

For example, given a set of coupons {1 2 4 -1}, and a set of product values {7 6 -2 -3} (in Mars dollars M$) where a negative value corresponds to a bonus product. You can apply coupon 3 (with N being 4) to product 1 (with value M$7) to get M$28 back; coupon 2 to product 2 to get M$12 back; and coupon 4 to product 4 to get M$3 back. On the other hand, if you apply coupon 3 to product 4, you will have to pay M$12 to the shop.

Each coupon and each product may be selected at most once. Your task is to get as much money back as possible.

Input Specification:

Each input file contains one test case. For each case, the first line contains the number of coupons NC, followed by a line with NC coupon integers. Then the next line contains the number of products NP, followed by a line with NP product values. Here 1<= NC, NP <= 105, and it is guaranteed that all the numbers will not exceed 230.

Output Specification:

For each test case, simply print in a line the maximum amount of money you can get back.

Sample Input:
4
1 2 4 -1
4
7 6 -2 -3
Sample Output:
43
ps:自己方法太挫了。。从大到小排序然后遍历,中间会遇到负数的问题。。。不进行优化还会超时。。
#include<iostream>
#include<string>
#include<cstdio>
#include<vector>
#include<algorithm>
#include<queue>
#include <cmath>
#include <map>
#include <set>
#include <string.h>
using namespace std;
vector<int> v1, v2;
bool cmp(int a, int b) {
	return a < b;
}
int main() {
	int n, m;
	cin >> n;
	v1.resize(n);
	for (int i = 0; i < n; i++) {
		cin >> v1[i];
	}
	cin >> m;
	v2.resize(m);
	for (int i = 0; i < m; i++) {
		cin >> v2[i];
	}
	sort(v1.begin(), v1.end(), cmp);
	sort(v2.begin(), v2.end(), cmp);
	int sum = 0, pos1 = 0, pos2 = 0;
	while (pos1 < n&&pos2 < m&&v1[pos1] < 0 && v2[pos2] < 0){
		sum += v1[pos1++] * v2[pos2++];
	}
	pos1 = n - 1, pos2 = m - 1;
	while (pos1 >= 0 && pos2 >= 0 && v1[pos1] > 0 && v2[pos2]>0) {
		sum += v1[pos1--] * v2[pos2--];
	}
		cout << sum<<endl;
	//cin >> n;
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值