PAT甲级 A1037

PAT甲级 A1037

题目详情

The magic shop in Mars is offering some magic coupons. Each coupon has an integer N printed on it, meaning that when you use this coupon with a product, you may get N times the value of that product back! What is more, the shop also offers some bonus product for free. However, if you apply a coupon with a positive N to this bonus product, you will have to pay the shop N times the value of the bonus product… but hey, magically, they have some coupons with negative N’s!

For example, given a set of coupons { 1 2 4 −1 }, and a set of product values { 7 6 −2 −3 } (in Mars dollars M$) where a negative value corresponds to a bonus product. You can apply coupon 3 (with N being 4) to product 1 (with value M$7) to get M$28 back; coupon 2 to product 2 to get M$12 back; and coupon 4 to product 4 to get M$3 back. On the other hand, if you apply coupon 3 to product 4, you will have to pay M$12 to the shop.

Each coupon and each product may be selected at most once. Your task is to get as much money back as possible.

Input Specification:
Each input file contains one test case. For each case, the first line contains the number of coupons N​C​​, followed by a line with N​C​​ coupon integers. Then the next line contains the number of products N​P​​, followed by a line with N​P​​ product values. Here 1≤N​C​​,N​P​​≤10​5​​, and it is guaranteed that all the numbers will not exceed 2​^30​​.

Output Specification:
For each test case, simply print in a line the maximum amount of money you can get back.

Sample Input:
4
1 2 4 -1
4
7 6 -2 -3

Sample Output:
43

解题思路

这题就是典型的贪心算法(最优子问题),两两组合最大的情况(可以不用完全组合,舍弃小于0的部分),因此在代码的过程中需要将问题分成两部分,两个数组中均为正数的或都为负数,一正一负排除。在都为正数的过程中,贪心策略每次选择两个序列中最大的正数相乘,在都为负数的过程中,贪心策略每次选择两个序列中最小的负数相乘。
AC代码如下:

#include<iostream>
#include<string>
#include<vector>
#include<cmath>
#include<string>
#include<algorithm>
#include<iomanip>
#include<map>
using namespace std;
vector<int> n1;
vector<int> n2;
int main() {
	int allnumber = 0;
	int N1; cin >> N1;
	for (int i = 0; i < N1; i++) {
		int temp; cin >> temp;
		n1.push_back(temp);
	}
	int N2; cin >> N2;
	for (int i = 0; i < N2; i++) {
		int temp; cin >> temp;
		n2.push_back(temp);
	}
	sort(n1.begin(), n1.end());
	sort(n2.begin(), n2.end());
	int i = 0; int j = 0;
	while (true) {
		if (i < n1.size() && j < n2.size() && n1[i] < 0 && n2[j] < 0) {
			allnumber += (n1[i] * n2[j]);
			i = i + 1;
			j = j + 1;
		}
		else {
			break;
		}
	}
	i = n1.size() - 1; j = n2.size() - 1;
	while (true) {
		if (i >= 0 && j >= 0 && n1[i] > 0 && n2[j] > 0) {
			allnumber += (n1[i] * n2[j]);
			i = i - 1;
			j = j - 1;
		}
		else {
			break;
		}
	}
	cout << allnumber << '\n';

}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值