LightOJ - 1259(素数筛法,数组过大用bool)

Goldbach's conjecture is one of the oldest unsolved problems in number theory and in all of mathematics. It states:

Every even integer, greater than 2, can be expressed as the sum of two primes [1].

Now your task is to check whether this conjecture holds for integers up to 107.


Input

Input starts with an integer T (≤ 300), denoting the number of test cases.

Each case starts with a line containing an integer n (4 ≤ n ≤ 107, n is even).

Output

For each case, print the case number and the number of ways you can express n as sum of two primes. To be more specific, we want to find the number of (a, b) where

1)      Both a and b are prime

2)      a + b = n

3)      a ≤ b

Sample Input

2

6

4

Sample Output

Case 1: 1

Case 2: 1

Hint

1.      An integer is said to be prime, if it is divisible by exactly two different integers. First few primes are 2, 3, 5, 7, 11, 13, ...

题意:给你一个数,求这个数由素数组成的方法有几种,这个数非常大,有1e7,int定义数组的话会超限,要用bool定义,还有就是跟我以前用的筛法有点不一样
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
const int maxn=1e7+1;
const int N=1e6;
bool a[maxn];
int prime[N],top;//top记录的是素数有几个,prinme里记录素数有哪几个
void aa()
{
    top = 0;
    a[1] = true;
    for(int i = 2; i < maxn; i++)
    {
        if(a[i]) continue;
        prime[top++] = i;
        for(int j = 2; j * i < maxn; j++)//因为maxn是1e7,当i跑到1e7时,j=i*i则j会超过int的范围,这样写避免了开long long
            a[j*i] = true;
    }
}
//void aa()
//{
//    top = 0;
//    a[1] = true;
//    for(long long i = 2; i < maxn; i++)
//    {
//        if(a[i]) continue;
//        prime[top++] = i;
//        for(long long j = i*i; j  < maxn; j+=i)//如同以上所说,要开long long
//            a[j] = true;
//    }
//}
int main()
{
    aa();
    int t,x,c;
    scanf("%d",&t);
    c=0;
    while(t--)
    {
        scanf("%d",&x);
        int ans=0;
        for(int i=0; i<top&&prime[i]<=x/2; i++)//直接从素数开始找
        {
            if(!a[x-prime[i]])//看x-素数是不是素数,是的话满足要求
                ans++;
        }
        printf("Case %d: %d\n",++c,ans);
    }
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值