POJ - 1265 Area (pick定理)

Being well known for its highly innovative products, Merck would definitely be a good target for industrial espionage. To protect its brand-new research and development facility the company has installed the latest system of surveillance robots patrolling the area. These robots move along the walls of the facility and report suspicious observations to the central security office. The only flaw in the system a competitor抯 agent could find is the fact that the robots radio their movements unencrypted. Not being able to find out more, the agent wants to use that information to calculate the exact size of the area occupied by the new facility. It is public knowledge that all the corners of the building are situated on a rectangular grid and that only straight walls are used. Figure 1 shows the course of a robot around an example area. 


 
Figure 1: Example area. 


You are hired to write a program that calculates the area occupied by the new facility from the movements of a robot along its walls. You can assume that this area is a polygon with corners on a rectangular grid. However, your boss insists that you use a formula he is so proud to have found somewhere. The formula relates the number I of grid points inside the polygon, the number E of grid points on the edges, and the total area A of the polygon. Unfortunately, you have lost the sheet on which he had written down that simple formula for you, so your first task is to find the formula yourself. 

Input

The first line contains the number of scenarios. 
For each scenario, you are given the number m, 3 <= m < 100, of movements of the robot in the first line. The following m lines contain pairs 揹x dy�of integers, separated by a single blank, satisfying .-100 <= dx, dy <= 100 and (dx, dy) != (0, 0). Such a pair means that the robot moves on to a grid point dx units to the right and dy units upwards on the grid (with respect to the current position). You can assume that the curve along which the robot moves is closed and that it does not intersect or even touch itself except for the start and end points. The robot moves anti-clockwise around the building, so the area to be calculated lies to the left of the curve. It is known in advance that the whole polygon would fit into a square on the grid with a side length of 100 units. 

Output

The output for every scenario begins with a line containing 揝cenario #i:� where i is the number of the scenario starting at 1. Then print a single line containing I, E, and A, the area A rounded to one digit after the decimal point. Separate the three numbers by two single blanks. Terminate the output for the scenario with a blank line.

Sample Input

2
4
1 0
0 1
-1 0
0 -1
7
5 0
1 3
-2 2
-1 0
0 -3
-3 1
0 -3

Sample Output

Scenario #1:
0 4 1.0

Scenario #2:
12 16 19.0

题意:给一些点,连成多边形,让你求多边形内部的点和边界上的点以及多边形的面积。

需要注意的是,输入不是坐标,而是当前点相对于上一个点的坐标距离,dx,dy,所以求的时候还要计算当前点坐标。

做这道题之前要学一下pick定理,pick定理讲的就是在一个网格中,一个多边形的顶点都在网格上,如果我们可以求得多边形边界上的点数a,多边形内部的点数b,那么面积s=a+b/2-1。

而边界上的点数b:对于aa(x1,y1),bb(x2,y2)所连成的选段,经过的格点的个数为gcd(abs(x1-x2),abs(y1-y2))+1。(包括端点)

我对于这个公式的理解,我们求出这个线段的两个端点坐标差值的最大公约数x,在坐标系上画出这个图,这个最大公约数x就是较小端点可以通过x次成比例的变化得到较大的端点。那么再算上本身那就是x+1个点数。

我们可以通过公式算出来b,再通过叉积算出来面积s,那么就能算a了。

还要注意的是因为这个题给出的图形不一定是凸包,凸包的话各个三角形叉积相加就是凸包面积,因为组成凸包的各个三角形叉积肯定大于0,而组成凹包的三角形的叉积可能就要小于0,画下图就能理解。所以我们要先加起来各个三角形的叉积再取绝对值。

在提示自己一次POJ的题G++要用%f提交,C++要用%lf,真的有毒,找一个多小时没找到bug,我之前就碰到过,当时被队友改了下就过了,果然只有自己碰到才刻骨铭心...

#include<stdio.h>
#include<string.h>
#include<math.h>
#include<algorithm>
using namespace std;
struct node
{
    int x,y;
}a[105];
int gcd(int a,int b)
{
    return b?gcd(b,a%b):a;
}
int cross(node a,node b)
{
    return a.x*b.y-a.y*b.x;
}
int main()
{
    int t,tt=0;
    scanf("%d",&t);
    while(t--)
    {
        tt++;
        int n;
        scanf("%d",&n);
        a[0].x=0;
        a[0].y=0;
        int aa=0,ans=0,dx,dy;
        for(int i=1;i<=n;i++)
        {
            scanf("%d%d",&a[i].x,&a[i].y);
            dx=a[i].x;
            dy=a[i].y;
            if(dx<0)
                dx=-dx;
            if(dy<0)
                dy=-dy;
            ans+=gcd(dx,dy);//因为dx和dy就是差值,所以直接用,并且我们是枚举每个点,不用再加自身那个点
            a[i].x+=a[i-1].x;
            a[i].y+=a[i-1].y;
            aa+=cross(a[i],a[i-1]);
        }
        if(aa<0)
            aa=-aa;
        printf("Scenario #%d:\n",tt);
        printf("%d %d %.1f\n\n",(aa+2-ans)/2,ans,aa*0.5);
    }
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值