HDU - 5858(acos返回的是弧度)

Problem Description
cjj is fun with math problem. One day he found a Olympic Mathematics problem for primary school students. It is too difficult for cjj. Can you solve it?


Give you the side length of the square L, you need to calculate the shaded area in the picture.

The full circle is the inscribed circle of the square, and the center of two quarter circle is the vertex of square, and its radius is the length of the square.
 

Input
The first line contains a integer T(1<=T<=10000), means the number of the test case. Each case contains one line with integer l(1<=l<=10000).
 

Output
For each test case, print one line, the shade area in the picture. The answer is round to two digit.
 

Sample Input
 
 
1 1
 

Sample Output
 
 
0.29
 
大佬博客: 点击打开链接
我的推导过程和他差不多,一道平面几何题,但是代码就很烦,以前没怎么学过几何,比赛就出岔子了,推出来了,但是代码问题很大,比如acos函数的返回值就是弧度,并不是角度,那么弧度要乘以180再除以π。
#include<stdio.h>
#include<string.h>
#include<math.h>
#include<queue>
#include<algorithm>
#define inf 0x3f3f3f3f
#define ll long long
#define maxx 5000000
using namespace std;
#define pi acos(-1)
int main()
{
    int t;
    double l;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%lf",&l);
        double r=l/2.0;
        double x=sqrt(2.0*l*l)/2.0;
        double a = (x*x + l*l -r*r)/(2.0*x*l);
        double s1 = l*x*sin(acos(a));
        double s2 = pi*l*l*2.0*acos(a)*180.0/pi/360.0;
        double b = (r*r+x*x-l*l)/(2.0*r*x);
        b = acos(b)*180.0/pi;
        b = 360.0 - 2.0*b;
        double s3 = pi*r*r*b/360.0;
        double ans = s3-(s2 - s1);
        printf("%.2lf\n",ans*2.0);
    }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值