LCS &编辑距离 比较

LCS

A subsequence of a given sequence is the given sequence with some elements (possible none) left out. Given a sequence X = <x1, x2, ..., xm> another sequence Z = <z1, z2, ..., zk> is a subsequence of X if there exists a strictly increasing sequence <i1, i2, ..., ik> of indices of X such that for all j = 1,2,...,k, xij = zj. For example, Z = <a, b, f, c> is a subsequence of X = <a, b, c, f, b, c> with index sequence <1, 2, 4, 6>. Given two sequences X and Y the problem is to find the length of the maximum-length common subsequence of X and Y. 
The program input is from a text file. Each data set in the file contains two strings representing the given sequences. The sequences are separated by any number of white spaces. The input data are correct. For each set of data the program prints on the standard output the length of the maximum-length common subsequence from the beginning of a separate line. 

Input

abcfbc abfcab
programming contest 
abcd mnp

Output

4
2
0

Sample Input

abcfbc abfcab
programming contest 
abcd mnp

Sample Output

4
2
0

ac代码

#include <iostream>
#include <string>
#include <cstring>
using namespace std;


int dp[1005][1005];
int main(){
	string s1,s2;
	while(cin>>s1>>s2){
		int l1,l2;
		
		l1=s1.length();
		l2=s2.length();
		memset(dp,0,sizeof(dp));
		for(int i=0;i<l1;i++)
		   for(int j=0;j<l2;j++){
		   		if(s1[i]==s2[j])
		   		    dp[i+1][j+1]=dp[i][j]+1;
		   		else 
				   	dp[i+1][j+1]=max(dp[i+1][j],dp[i][j+1]); 
			}
		cout<<dp[l1][l2]<<endl;
	}
	
}

 

编辑距离

编辑距离,又称Levenshtein距离(也叫做Edit Distance),是指两个字串之间,由一个转成另一个所需的最少编辑操作次数。许可的编辑操作包括将一个字符替换成另一个字符,插入一个字符,删除一个字符。

例如将kitten一字转成sitting:

sitten (k->s)

sittin (e->i)

sitting (->g)

所以kitten和sitting的编辑距离是3。俄罗斯科学家Vladimir Levenshtein在1965年提出这个概念。

给出两个字符串a,b,求a和b的编辑距离。

Input

第1行:字符串a(a的长度 <= 1000)。 
第2行:字符串b(b的长度 <= 1000)。

Output

输出a和b的编辑距离

Sample Input

kitten
sitting

Sample Output

3
#include <iostream>
#include<bits/stdc++.h>
#define ll long long
using namespace std;
char s[2][1500];
int dp[1500][1100];
int main()
{
   cin>>s[0];
   cin>>s[1];
   int len1=strlen(s[0]);
   int len2=strlen(s[1]);
for(int i=0;i<=len1;i++)dp[i][0]=i;
for(int i=0;i<=len2;i++)dp[0][i]=i;
for(int i=1;i<=len1;i++)
    for(int j=1;j<=len2;j++)
{
    dp[i][j]=min(dp[i-1][j],dp[i][j-1])+1;
    dp[i][j]=min(dp[i][j],dp[i-1][j-1]+(s[0][i-1]!=s[1][j-1]?1:0));
}
    printf("%d\n",dp[len1][len2]);
}

 

  • 2
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值