【hdu】A Simple Problem with Integers (线段树)

A Simple Problem with Integers

Time Limit : 10000/5000ms (Java/Other)   Memory Limit : 262144/131072K (Java/Other)
Total Submission(s) : 4   Accepted Submission(s) : 3
Problem Description

You have N integers, A1, A2, ... ,AN. You need to deal with two kinds of operations. One type of operation is to add some given number to each number in a given interval. The other is to ask for the sum of numbers in a given interval.

 

Input

The first line contains two numbers N and Q. 1 ≤ N,Q ≤ 100000.
The second line contains N numbers, the initial values of A1,A2, ... , AN. -1000000000 ≤ Ai ≤ 1000000000.
Each of the next Q lines represents an operation.
"C a b c" means adding c to each of Aa, Aa+1, ... , Ab. -10000 ≤ c ≤ 10000.
"Q a b" means querying the sum of Aa, Aa+1, ... ,Ab.

 

Output

You need to answer all Q commands in order. One answer in a line.

 

Sample Input
   
   
10 5 1 2 3 4 5 6 7 8 9 10 Q 4 4 Q 1 10 Q 2 4 C 3 6 3 Q 2 4
 

Sample Output
   
   
4 55 9 15
 

Source
PKU

#include<iostream>
#include<cstdio>
#define LL long long 
int num[100005]; 
struct segtree
{
       int left,right;
       LL sum,add;
       int mid(){return (left+right)>>1; }
}tree[400005];
void PushUp(int pos)
{
     tree[pos].sum=tree[pos<<1].sum+tree[pos<<1|1].sum;
} 
void PushDown(int pos)
{
     int L=tree[pos].left;
     int R=tree[pos].right;
     int M=tree[pos].mid();
     if(tree[pos].add!=0)
     {
          tree[pos<<1].add+=tree[pos].add;     
          tree[pos<<1|1].add+=tree[pos].add; 
          tree[pos<<1].sum+=(M-L+1)*tree[pos].add;
          tree[pos<<1|1].sum+=(R-M)*tree[pos].add;
          tree[pos].add=0;
     } 
}
void Build(int pos,int x,int y)
{
     
     tree[pos].left=x;
     tree[pos].right=y;
     tree[pos].add=0;
     if(x==y) {tree[pos].sum=num[x];return ;}
     int m=tree[pos].mid(); 
     Build(pos<<1,x,m);
     Build(pos<<1|1,m+1,y);
     PushUp(pos);
} 
    
void Update(int pos,int a,int b,LL  c) 
{   
     int L=tree[pos].left;
     int R=tree[pos].right;
     int M=tree[pos].mid();
     if(L>=a&&R<=b)
     {
                   tree[pos].add+=c;  
                   tree[pos].sum+=(R-L+1)*tree[pos].add;    
                   return ;
     }
     PushDown(pos);
     if(a<=M) Update(pos<<1,a,b,c);
     if(b>M) Update(pos<<1|1,a,b,c);
     PushUp(pos);    
}    
LL Query(int pos,int a,int b)
{
     int L=tree[pos].left;
     int R=tree[pos].right;
     int M=tree[pos].mid();
     LL k1=0,k2=0;
     if(L>=a&&R<=b) return tree[pos].sum;   
     PushDown(pos);              
     if(a<=M) k1= Query(pos<<1,a,b);
     if(b>M)k2= Query(pos<<1|1,a,b);
     return k1+k2;    
}
int main()
{
    int a,b,c,N,Q,i;
    char s[2]; 
    scanf("%d%d",&N,&Q);
    for(i=1;i<=N;i++)
    {
           scanf("%d",&num[i]);
    }
    Build(1,1,N); 
    for(i=1;i<=Q;i++)
    {
           scanf("%s",s);
           switch(s[0])
           {
                       case 'Q':  
                            scanf("%d%d",&a,&b);
                            printf("%lld\n",Query(1,a,b));
                            break; 
                       case 'C':
                            scanf("%d%d%d",&a,&b,&c);
                            Update(1,a,b,c);
                            break; 
           } 
    }
    return 0;
}       
     


#include <iostream>

#include <algorithm>

#include <cstdio>

#include <cstring>

using namespace std;


#define lson l,m,rt<<1

#define rson m+1,r,rt<<1|1

#define LL long long

const int maxn = 120000;

LL add[maxn<<2];

LL sum[maxn<<2];


void PushUp(int rt)

{

    sum[rt] = sum[rt<<1] + sum[rt<<1|1];

}


void PushDown(int rt,int m)

{

    if (add[rt])

    {

        add[rt<<1] +=add[rt];

        add[rt<<1|1] +=add[rt];

        sum[rt<<1] +=add[rt]*(m-(m>>1));

        sum[rt<<1|1] +=add[rt]*(m>>1);

        add[rt]=0;

    }

}


void build(int l,int r,int rt=1)

{

    add[rt]=0;

    if (l==r)

    {

        scanf("%lld",&sum[rt]);

        return;

    }

    int m = (l+r)>>1;

    build(lson);

    build(rson);

    PushUp(rt);

}


void update(int L,int R,int c,int l,int r,int rt=1)

{

    if (L<=l && r<=R)

    {

        add[rt]+=c;

        sum[rt]+=(LL)c*(r-l+1);

        return;

    }

    PushDown(rt,r-l+1);

    int m = (l+r)>>1;

    if (L<=m) update(L,R,c,lson);

    if (R>m) update(L,R,c,rson);

    PushUp(rt);

}


LL query(int L,int R,int l,int r,int rt=1)

{

    if (L<=l && r<=R)

    {

        return sum[rt];

    }

    

    PushDown(rt, r-l+1);

    int m = (l+r)>>1;

    LL ret = 0;

    if (L<=m) ret +=query(L,R,lson);

    if (m<R) ret +=query(L,R,rson);

    return ret;

}


int main()

{

    int n,q;

    scanf("%d%d",&n,&q);

    build(1,n);

    while (q--)

    {

        char os[2];

        int x,y,z;

        scanf("%s",os);

        if (os[0]=='Q')

        {

            scanf("%d%d",&x,&y);

            printf("%lld\n",query(x,y,1,n));

        }

        else {

            scanf("%d%d%d",&x,&y,&z);

            update(x,y,z,1,n);

        }

    }

    return 0;

}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值