【hdu】 Charm Bracelet 01背包


Charm Bracelet

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 131072/65536K (Java/Other)
Total Submission(s) : 16   Accepted Submission(s) : 14
Problem Description

Bessie has gone to the mall's jewelry store and spies a charm bracelet. Of course, she'd like to fill it with the best charms possible from the N (1 ≤ N ≤ 3,402) available charms. Each charm i in the supplied list has a weight Wi (1 ≤ Wi ≤ 400), a 'desirability' factor Di (1 ≤ Di ≤ 100), and can be used at most once. Bessie can only support a charm bracelet whose weight is no more than M (1 ≤ M ≤ 12,880).

Given that weight limit as a constraint and a list of the charms with their weights and desirability rating, deduce the maximum possible sum of ratings.

 

Input

* Line 1: Two space-separated integers: N and M
* Lines 2..N+1: Line i+1 describes charm i with two space-separated integers: Wi and Di

 

Output

* Line 1: A single integer that is the greatest sum of charm desirabilities that can be achieved given the weight constraints

 

Sample Input
    
    
4 6 1 4 2 6 3 12 2 7
 

Sample Output
    
    
23
 

Source
PKU
 
#include<cstdio>
#include<cstring>
using namespace std;
int max(int a,int b) {return a>b?a:b;}
int val[3405],c[3405],f[100 * 3500];
int main()
{
    int T,N,V,i,j;
    scanf("%d%d",&N,&V);
    for(i=1;i<=N;i++)
       scanf("%d%d",&c[i],&val[i]);
    memset(f, 0, sizeof(f));  
    for(i=1;i<=N;i++)
        for(j=V;j>=c[i];j--)
                 {
                    
                     f[j]=max(f[j],f[j-c[i]]+val[i]);         
                 }
        printf("%d\n",f[V]);                  
} 


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值