POJ -3641Pseudoprime numbers(快速幂+同余定理)

20 篇文章 0 订阅
5 篇文章 0 订阅

Description
Fermat's theorem states that for any prime number p and for any integer a > 1, ap = a (mod p). That is, if we raise a to the pth power and divide by p, the remainder is a. Some (but not very many) non-prime values of p, known as base-a pseudoprimes, have this property for some a. (And some, known as Carmichael Numbers, are base-a pseudoprimes for all a.)
Given 2 < p ≤ 1000000000 and 1 < a < p, determine whether or not p is a base-a pseudoprime.
Input
Input contains several test cases followed by a line containing "0 0". Each test case consists of a line containing p and a.
Output
For each test case, output "yes" if p is a base-a pseudoprime; otherwise output "no".
Sample Input
3 2
10 3
341 2
341 3
1105 2
1105 3
0 0
Sample Output
no
no
yes
no
yes

yes

题意:给你两个数p和a,如果a的p次方对p取余等于a并且p不是素数,输出yes,否则输出no。

思路:因为数据过大,直接写for循环求次方会超时.这里就要用到快速幂这个技巧了.简单说就是降幂,比如说a的b次方,如果b是偶数,该数就可以表示为(a^2)^(b/2),如果b是奇数,可以 另写一个数保存此时的底数然后幂数减1,又可以继续降幂了,知道最后。优化代码。注意__int64输入防止爆int

代码:

#include<cstdio>
int quickpow(__int64 n,__int64 m,__int64 mod)//n是底数,m是幂数,mod是取余数
{
	__int64 ans=1,base=n;
	while(m)
	{
		if(m&1)//如果幂数是奇数,则将底数保存在ans中,这样幂数-1变成偶数就可以继续降幂了。 base是幂数。

		{
			ans=(base*ans)%mod;//保存并更新多幂底数
		}
		base=(base*base)%mod;//更新底数
		m/=2;//更新幂数 
	}
	return ans;
}
int main()
{
	__int64 n,m;
	__int64 mod;
	while(scanf("%I64d%I64d",&n,&m)&&n||m)
	{
		int sum=0;
		for(int i=2;i*i<n;i++)
		{
			if(n%i==0)
			sum++;
		}
		if(sum==0)
		printf("no\n");
		else
		{
		mod=n;
		if(quickpow(m,n,mod)==m)
		printf("yes\n");
		else
		printf("no\n");		
		}	
	}
	return 0;
}


  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值