LightOJ1137Expanding Rods(二分)

8 篇文章 0 订阅
7 篇文章 0 订阅
Description
When a thin rod of length L is heated n degrees, it expands to a new length L' = (1+n*C)*L, where C is the coefficient of heat expansion.



When a thin rod is mounted on two solid walls and then heated, it expands and takes the shape of a circular segment, the original rod being the chord of the segment.

Your task is to compute the distance by which the center of the rod is displaced. That means you have to calculate h as in the picture.

Input
Input starts with an integer T (≤ 20), denoting the number of test cases.

Each case contains three non-negative real numbers: the initial length of the rod in millimeters L, the temperature change in degrees n and the coefficient of heat expansion of the material C. Input data guarantee that no rod expands by more than one half of its original length. All the numbers will be between 0 and 1000 and there can be at most 5 digits after the decimal point.

Output
For each case, print the case number and the displacement of the center of the rod in single line. Errors less than 10-6 will be ignored.

Sample Input
3
1000 100 0.0001
150 10 0.00006
10 0 0.001
Sample Output
Case 1: 61.3289915
Case 2: 2.2502024857

Case 3: 0

题意:一根细棍受热会变长,现在将它固定在两墙之间,受热他就会向上弯曲,给了你棍长,受热还有系数,以及受热伸长的公式,问你受热后向上弯曲多高?

思路:这里有两个数学公式要用,r(圆半径)=(4*h*h+l*l)/8*h,s(棍长)=2*r*arcsin(l/2*r);再利用二分法求的高度。

代码:

#include<cstdio>
#include<iostream>
#include<algorithm>
#include<string.h>
#include<math.h>
#define eps 1e-12
double l,r;
double w(double x)
{
	double t;
	r=(4*x*x+l*l)/(8*x);
	t=2*r*asin(l/(2*r));
	return t; 
}
using namespace std;
int main()
{
	int t;
	scanf("%d",&t);
	int k=1;
	while(t--)
	{
		double n,c,q;
		scanf("%lf %lf %lf",&l,&n,&c);
		q=(1+n*c)*l;
		double s=0.0,e=l/2.0,mid=0.0;
		while(s<=e-eps)
		{
			mid=(s+e)/2.0;
			if(w(mid)<q)
			{
				s=mid+eps;
			}
			else
			{
				e=mid-eps;
			}
		}
		printf("Case %d: %lf\n",k++,mid);
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值