lightoj1137【二分】


D - Expanding Rods

Time Limit:500MS     Memory Limit:32768KB     64bit IO Format:%lld & %llu

Description

When a thin rod of length L is heated n degrees, it expands to a new length L' = (1+n*C)*L, where C is the coefficient of heat expansion.

When a thin rod is mounted on two solid walls and then heated, it expands and takes the shape of a circular segment, the original rod being the chord of the segment.

Your task is to compute the distance by which the center of the rod is displaced. That means you have to calculate h as in the picture.

Input

Input starts with an integer T (≤ 20), denoting the number of test cases.

Each case contains three non-negative real numbers: the initial length of the rod in millimeters L, the temperature change in degrees n and the coefficient of heat expansion of the material C. Input data guarantee that no rod expands by more than one half of its original length. All the numbers will be between 0 and 1000 and there can be at most 5 digits after the decimal point.

Output

For each case, print the case number and the displacement of the center of the rod in single line. Errors less than 10-6 will be ignored.

Sample Input

3

1000 100 0.0001

150 10 0.00006

10 0 0.001

Sample Output

Case 1: 61.3289915

Case 2: 2.2502024857

Case 3: 0

题意:如图给出原长和加热后的长度求h
解题思路:二分在poj上也有此题不过poj此题很坑
#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<cmath>
#define PI acos(-1.0)
using namespace std;
int main()
{
	int t,i,j,k=1;
	double l,n,c;
	scanf("%d",&t);
	while(t--){
		scanf("%lf%lf%lf",&l,&n,&c);
		double left=0,right=PI/2.0;
		int size=100;
		double l1=(1+n*c)*l;
		while(size--){
			double mid=(left+right)/2.0;
			if(mid*l/(sin(mid))>l1)
				right=mid;
			else left=mid;
		}
		printf("Case %d: %.7lf\n",k++,0.5*l/sin(left)-0.5*l/tan(left));
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值