POJ 2377Bad Cowtractors(并查集+Sort)

20 篇文章 0 订阅
18 篇文章 0 订阅
Description
Bessie has been hired to build a cheap internet network among Farmer John's N (2 <= N <= 1,000) barns that are conveniently numbered 1..N. FJ has already done some surveying, and found M (1 <= M <= 20,000) possible connection routes between pairs of barns. Each possible connection route has an associated cost C (1 <= C <= 100,000). Farmer John wants to spend the least amount on connecting the network; he doesn't even want to pay Bessie.

Realizing Farmer John will not pay her, Bessie decides to do the worst job possible. She must decide on a set of connections to install so that (i) the total cost of these connections is as large as possible, (ii) all the barns are connected together (so that it is possible to reach any barn from any other barn via a path of installed connections), and (iii) so that there are no cycles among the connections (which Farmer John would easily be able to detect). Conditions (ii) and (iii) ensure that the final set of connections will look like a "tree".
Input
* Line 1: Two space-separated integers: N and M

* Lines 2..M+1: Each line contains three space-separated integers A, B, and C that describe a connection route between barns A and B of cost C.
Output
* Line 1: A single integer, containing the price of the most expensive tree connecting all the barns. If it is not possible to connect all the barns, output -1.
Sample Input
5 8
1 2 3
1 3 7
2 3 10
2 4 4
2 5 8
3 4 6
3 5 2
4 5 17
Sample Output

42

题意:找到能使这些数相连的不构成环的最远路。

思路:并查集查找,先快排按路径远排,一个一个查找添加,如果符合题意且没查过加进去,不符合查下一个,判断有几个n节点,超过一个就证明有城市没有连接上。一个的话直接输出多远就好了(因为远的放在前面,所以这样排查找后肯定最远)。这道题我就试探性做一下直接对了哈哈

代码:

#include<stdio.h>
#include<iostream>
#include<algorithm>
#include<string.h>
#include<queue>
#include<stack>
#include<math.h>
using namespace std;
int pre[20010];
int find(int x)
{
	int r=x;
	while(pre[r]!=r)
	r=pre[r];
	return r;
}
void join(int x,int y)
{
	int fx=find(x),fy=find(y);
	if(fx!=fy)
	pre[fx]=fy;
}
struct st{
	int s;
	int e;
	int p;
}a[20010];
bool cmp(st x,st y)
{
	return x.p>y.p;
}
int main()
{
	int n,m;
	while(~scanf("%d%d",&n,&m))
	{
		memset(a,0,sizeof(a));
		memset(pre,0,sizeof(pre));
		for(int i=0;i<m;i++)
		scanf("%d %d %d",&a[i].s,&a[i].e,&a[i].p);
		sort(a,a+m,cmp);
		int sum=0;
		for(int i=0;i<n;i++)
		pre[i]=i;
		for(int i=0;i<m;i++)
		{
			if(find(a[i].s)!=find(a[i].e))
			{
				join(a[i].s,a[i].e);
				sum+=a[i].p;
			}
		}
		int ans=0;
		for(int i=0;i<n;i++)
		{
			if(pre[i]==i)
			ans++;	
		}
		if(ans>1)
		printf("-1\n");
		else
		printf("%d\n",sum);
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值