LightOJ 1043Triangle Partitioning(数学)

29 篇文章 0 订阅
18 篇文章 0 订阅
Description
See the picture below.



You are given AB, AC and BC. DE is parallel to BC. You are also given the area ratio between ADE and BDEC. You have to find the value of AD.

Input
Input starts with an integer T (≤ 25), denoting the number of test cases.

Each case begins with four real numbers denoting AB, AC, BC and the ratio of ADE and BDEC (ADE / BDEC). You can safely assume that the given triangle is a valid triangle with positive area.

Output
For each case of input you have to print the case number and AD. Errors less than 10-6 will be ignored.

Sample Input
4
100 100 100 2
10 12 14 1
7 8 9 10
8.134 9.098 7.123 5.10
Sample Output
Case 1: 81.6496580
Case 2: 7.07106781
Case 3: 6.6742381247

Case 4: 7.437454786

题意:告诉你边长AB.BC.AC.还有ADE和BDCE的面积比,还有DE平行BC,问你AD多长

思路:简单的数学推导就好了

代码:

#include<cstdio>
#include<iostream>
#include<algorithm>
#include<math.h>
using namespace std;
int main()
{
	int t;
	scanf("%d",&t);
	int k=1;
	while(t--)
	{
		double a,b,c,r;
		scanf("%lf %lf %lf %lf",&a,&b,&c,&r);
		double q=sqrt((r/(r+1))*a*a);
		printf("Case %d: %lf\n",k++,q);
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值