Stall Reservations POJ - 3190

Stall Reservations

POJ - 3190




Oh those picky N (1 <= N <= 50,000) cows! They are so picky that each one will only be milked over some precise time interval A..B (1 <= A <= B <= 1,000,000), which includes both times A and B. Obviously, FJ must create a reservation system to determine which stall each cow can be assigned for her milking time. Of course, no cow will share such a private moment with other cows.

Help FJ by determining:
  • The minimum number of stalls required in the barn so that each cow can have her private milking period
  • An assignment of cows to these stalls over time
Many answers are correct for each test dataset; a program will grade your answer.
Input
Line 1: A single integer, N

Lines 2..N+1: Line i+1 describes cow i's milking interval with two space-separated integers.
Output
Line 1: The minimum number of stalls the barn must have.

Lines 2..N+1: Line i+1 describes the stall to which cow i will be assigned for her milking period.
Sample Input
5
1 10
2 4
3 6
5 8
4 7
Sample Output
4
1
2
3
2
4
Hint
Explanation of the sample:

Here's a graphical schedule for this output:

Time     1  2  3  4  5  6  7  8  9 10

Stall 1 c1>>>>>>>>>>>>>>>>>>>>>>>>>>>

Stall 2 .. c2>>>>>> c4>>>>>>>>> .. ..

Stall 3 .. .. c3>>>>>>>>> .. .. .. ..

Stall 4 .. .. .. c5>>>>>>>>> .. .. ..
Other outputs using the same number of stalls are possible.

题意:每个奶牛在一段特定的时间内都要独自占用一个兽栏,判断最少需要几个兽栏。

分析:把奶牛按照开始的时间排序,利用优先队列保存兽栏的使用的结束时间(如果连结束时间最早的都不能用的话,别的一定也不能用),贪心,每次都选择开始时间最早的奶牛,判断能不能放入结束时间最早的兽栏里,能则放入,更新兽栏,不能,则建立新兽栏,兽栏个数加一。

收获:部分贪心,对于一个类的多种元素,抓住某个具有决定性的因素,进行贪心问题往往就能得到简化。

代码:

#include<cstdio>
#include<algorithm>
#include<queue>
#include<iostream>
using namespace std;
struct node
{
    int x,y,c;
    friend bool operator<(node a,node b)//一定要加friend,从小到大排序
    {
        return a.y>b.y;
    }
}p[50005];
bool cmp(node a,node b)
{
    return a.x<b.x;
}
int t[50005];
int main()
{
    int i,j,n;
   scanf("%d",&n);
        for(i=0;i<n;i++)
        {
            scanf("%d%d",&p[i].x,&p[i].y);
            p[i].c=i;
        }
        int r=0;
        sort(p,p+n,cmp);//将牛排序
        priority_queue<node>q;//建立以结束时间早为优先的队列
        q.push(p[0]);
        t[p[0].c]=++r;//利用数组t来链式的记录哪个奶牛使用了哪个兽栏
        for(i=1;i<n;i++)
        {
            node g=q.top();
            if(g.y<p[i].x)
            {
                t[p[i].c]=t[g.c];
                q.pop();
                q.push(p[i]);
            }
            else
            {
                t[p[i].c]=++r;
                q.push(p[i]);
            }
        }
        printf("%d\n",r);
    for(int i=0;i<n;i++)
        printf("%d\n",t[i]);
    return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值