POJ-3190 Stall Reservations(贪心)

Oh those picky N (1 <= N <= 50,000) cows! They are so picky that each one will only be milked over some precise time interval A..B (1 <= A <= B <= 1,000,000), which includes both times A and B. Obviously, FJ must create a reservation system to determine which stall each cow can be assigned for her milking time. Of course, no cow will share such a private moment with other cows.

Help FJ by determining: The minimum number of stalls required in the
barn so that each cow can have her private milking period An
assignment of cows to these stalls over time Many answers are correct
for each test dataset; a program will grade your answer.

Input

Line 1: A single integer, N

Lines 2..N+1: Line i+1 describes cow i’s milking interval with two
space-separated integers.

Output

Line 1: The minimum number of stalls the barn must have.

Lines 2..N+1: Line i+1 describes the stall to which cow i will be
assigned for her milking period.

Sample Input

5
1 10
2 4
3 6
5 8
5 8
4 7

Sample Output

4
1
2
3
2
4

Hint

Explanation of the sample:
Here’s a graphical schedule for this output:
Time 1 2 3 4 5 6 7 8 9 10
Stall 1 c1>>>>>>>>>>>>>>>
Stall 2 .. c2>>>>>>c4>>>>>>
Stall 3 .. .. c3 >>>>>>>>> .. ..
Stall 4 .. .. .. c5>>>>>>>>> ..
Other outputs using the same number of stalls are possible.

贪心的题我是真的不太会,,,大概是真的全靠猜了
猜想是按起始的时间排个序,按顺序看每头奶牛。如果没有冲突就可以放在同一个地方。
想着用set排序,于是用了一个结构体存储结束和开始的时间。
然后直接输出了结果。
看起来过来样例,结果还是WA了
后来才想起来,排序以后,奶牛的顺序也变了。
于是在结构体里面又加入了奶牛的编号。
在分配位置的时候,用另一个数组,按编号直接保存结果。
然后输出结果就可以了。
代码如下

#include<iostream>
#include<cstring>
#include<string>
#include<cmath>
#include<map>
#include<queue>
#include<vector>
#include<algorithm>
#include<stdio.h>
#include<cstdio>
#define Max 100000

using namespace std;

typedef struct m
{
    int a,b;
    int c;
    int d;
};

bool cmp1(m a,m b)
{
    if(a.a>=b.a)
        return false;
    else return true;
}
bool cmp2(m a,m b)
{
    if(a.d>=b.d)
        return false;
    else return true;
}

int main()
{
    int T,N;
    int i,j,k,mx;
    int a[50000];
    m b[50000];
    int t[50000];
    while(cin>>N)
    {
        mx=0;
        memset(a,-1,sizeof(a));
        for(i=0; i<N; i++)
        {
            scanf("%d %d",&b[i].a,&b[i].b);
            b[i].d=i;
        }
        sort(b,b+N,cmp1);
        for(i=0; i<N; i++)
        {
            j=0;
            if(b[i].a>a[j])
            {
                a[j]=b[i].b;
                b[i].c=j;
                t[b[i].d]=j;
            }
            else
            {
                while(b[i].a<=a[j])
                    j++;
                a[j]=b[i].b;
                b[i].c=j;
                t[b[i].d]=j;
                if(j>=mx)
                    mx=j;
            }
        }
        cout<<mx+1<<endl;
        for(i=0;i<N;i++)
            printf("%d\n",t[i]+1);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值