Six Degrees of Cowvin Bacon POJ - 2139(floyd)


The cows have been making movies lately, so they are ready to play a variant of the famous game "Six Degrees of Kevin Bacon".

The game works like this: each cow is considered to be zero degrees of separation (degrees) away from herself. If two distinct cows have been in a movie together, each is considered to be one 'degree' away from the other. If a two cows have never worked together but have both worked with a third cow, they are considered to be two 'degrees' away from each other (counted as: one degree to the cow they've worked with and one more to the other cow). This scales to the general case.

The N (2 <= N <= 300) cows are interested in figuring out which cow has the smallest average degree of separation from all the other cows. excluding herself of course. The cows have made M (1 <= M <= 10000) movies and it is guaranteed that some relationship path exists between every pair of cows.
Input
* Line 1: Two space-separated integers: N and M

* Lines 2..M+1: Each input line contains a set of two or more space-separated integers that describes the cows appearing in a single movie. The first integer is the number of cows participating in the described movie, (e.g., Mi); the subsequent Mi integers tell which cows were.
Output
* Line 1: A single integer that is 100 times the shortest mean degree of separation of any of the cows.
Sample Input
4 2
3 1 2 3
2 3 4
Sample Output
100
Hint
[Cow 3 has worked with all the other cows and thus has degrees of separation: 1, 1, and 1 -- a mean of 1.00 .]

题意:奶牛A和B如果一起演过电影他们的距离就是1,如果A和B一起演过B和C一起演过那么 A和C的距离就是2,依次类推。求哪个奶牛和其他奶牛的距离的和最大,输出最大值

分析:抽象之后其实就是无向图的最短路问题,建立路径,floyd。

收获:一开始没想到floyd,这个求最短路的题意不是很明显没看出来,还是要加深算法的理解

AC:

#include <iostream>
#include <cstdio>
#include <cstdlib>
#include <algorithm>
 

using namespace std;
const int maxn = 300 + 10;
const int inf = 0x3f3f3f3f;
 

int n, m;
int g[maxn][maxn];
int x[maxn];

void floyd()
{
    for (int k = 0; k < n; k++)
    {
        for (int i = 0; i < n; i++)
        {
            for (int j = 0; j < n; j++)
            {
                g[i][j] = min(g[i][j], g[i][k] + g[k][j]);
            }
        }
    }
}

int main()
{
 
    while (~scanf("%d%d", &n, &m))
    {
        memset(g, inf, sizeof(g));
        for (int i = 0; i < n; i++)
            g[i][i] = 0;
        while (m--)
        {
            int num;
            scanf("%d", &num);
            for (int i = 0; i < num; i++)
            {
                scanf("%d", &x[i]);
                x[i]--;
            }
            for (int i = 0; i < num; i++)
            {
                for (int j = i + 1; j < num; j++)
                {
                    g[x[i]][x[j]] = g[x[j]][x[i]] = 1;
                }
            }
        }
        floyd();
        int ans = inf;
        for (int i = 0; i < n; i++)
        {
            int sum = 0;
            for (int j = 0; j < n; j++)
            {
                sum += g[i][j];
            }
            ans = min(sum, ans);
        }
        printf("%d\n", 100 * ans / (n - 1));
    }
    return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值