Six Degrees of Cowvin Bacon POJ - 2139 (floyd求最短路)

Six Degrees of Cowvin Bacon

POJ - 2139

The cows have been making movies lately, so they are ready to play a variant of the famous game "Six Degrees of Kevin Bacon".

The game works like this: each cow is considered to be zero degrees of separation (degrees) away from herself. If two distinct cows have been in a movie together, each is considered to be one 'degree' away from the other. If a two cows have never worked together but have both worked with a third cow, they are considered to be two 'degrees' away from each other (counted as: one degree to the cow they've worked with and one more to the other cow). This scales to the general case.

The N (2 <= N <= 300) cows are interested in figuring out which cow has the smallest average degree of separation from all the other cows. excluding herself of course. The cows have made M (1 <= M <= 10000) movies and it is guaranteed that some relationship path exists between every pair of cows.
Input
* Line 1: Two space-separated integers: N and M

* Lines 2..M+1: Each input line contains a set of two or more space-separated integers that describes the cows appearing in a single movie. The first integer is the number of cows participating in the described movie, (e.g., Mi); the subsequent Mi integers tell which cows were.
Output
* Line 1: A single integer that is 100 times the shortest mean degree of separation of any of the cows.
Sample Input
4 2
3 1 2 3
2 3 4
Sample Output
100
Hint
[Cow 3 has worked with all the other cows and thus has degrees of separation: 1, 1, and 1 -- a mean of 1.00 .]

题意:两头牛在一个电影中出现,那么他们之间算作1(连通),如果两头牛没有在一个电影中过,但是有一头牛和这两头牛分别在同一个电影中过,则这两头牛之间也算作1,
这样一想就是一个图,给定a b说明ab直接相连给定ab bc  则ac也间接相连,求一个牛到其他所有的牛的距离最小(每个距离为1),就是求最短路,可以用弗洛伊德算法,然后枚举每个点,最终得到结果
code:
#include <iostream>
#include <cstring>
using namespace std;
#define INF 0x3f3f3f3f
int G[303][303];
int n,m;
int x[303];
int main(){
    memset(G,INF,sizeof(G));
    cin >> n >> m;
    int i,j,k;
    for(i = 0; i < n; i++)
        G[i][i] = 0;//必须有这句
    while(m--){
        int num;
        cin >> num;
        for(i = 0; i < num; i++){
            cin >> x[i];
            --x[i];
        }
        for(i = 0; i < num; i++){
            for(j = i+1; j < num; j++){
                G[x[i]][x[j]] = 1;
                G[x[j]][x[i]] = 1;
            }
        }
    }
    //folyd
    for(k = 0; k < n; k++){
        for(i = 0; i < n; i++){
            for(j = 0; j < n; j++){
                G[i][j] = min(G[i][j],G[i][k]+G[k][j]);
            }
        }
    }
    int sum,ans = INF;
    for(i = 0; i < n; i++){
        sum = 0;
        for(j = 0; j < n; j++){
            sum += G[i][j];
        }
        ans = min(ans,sum);
    }
    cout << 100*ans/(n-1) << endl;//n-1 except himself
    return 0;
}




  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值