POJ - 2139 Six Degrees of Cowvin Bacon(图论/无权最短路径BFS)

8 篇文章 1 订阅
8 篇文章 0 订阅

问题描述
The cows have been making movies lately, so they are ready to play a variant of the famous game “Six Degrees of Kevin Bacon”.

The game works like this: each cow is considered to be zero degrees of separation (degrees) away from herself. If two distinct cows have been in a movie together, each is considered to be one ‘degree’ away from the other. If a two cows have never worked together but have both worked with a third cow, they are considered to be two ‘degrees’ away from each other (counted as: one degree to the cow they’ve worked with and one more to the other cow). This scales to the general case.

The N (2 <= N <= 300) cows are interested in figuring out which cow has the smallest average degree of separation from all the other cows. excluding herself of course. The cows have made M (1 <= M <= 10000) movies and it is guaranteed that some relationship path exists between every pair of cows.

Input
Line 1: Two space-separated integers: N and M
Lines 2..M+1: Each input line contains a set of two or more space-separated integers that describes the cows appearing in a single movie. The first integer is the number of cows participating in the described movie, (e.g., Mi); the subsequent Mi integers tell which cows were.

Output
Line 1: A single integer that is 100 times the shortest mean degree of separation of any of the cows.

Sample Input

4 2
3 1 2 3
2 3 4

Sample Output

100

分析:

代码如下:

#include<cstdio>
#include<cstring>
#include<queue>
using namespace std; 
const int maxn = 300+10;
const int INF = 1000000000; 
int N, M;
int d[maxn];
bool known[maxn];
int map[maxn][maxn];

void BFS(int s)
{
    queue<int> q;
    q.push(s);
    d[s] = 0;
    known[s] = true;
    while(!q.empty())
    {
        int u = q.front(); q.pop();
        for(int i=1; i<=N; i++)
        {
            if(known[i] == false && map[u][i])
            {
                known[i] = true;
                d[i] = d[u] + 1;
                q.push(i);
            }
        }
    }
    return;
}
int main()
{
    scanf("%d%d",&N,&M);
    int num;
    int k[5000];
    for(int i=0; i<M; i++)
    {
        scanf("%d",&num);
        for(int i=0; i<num; i++)
        {
            scanf("%d",&k[i]);
        }
        for(int i=0; i<num; i++)
        {
            for(int j=i+1; j<num; j++)
            {
                map[k[i]][k[j]] = 1;
                map[k[j]][k[i]] = 1;
            }
        }
    }
    int Min = INF;
    for(int i=1; i<=N; i++)
    {
        memset(d, 0, sizeof(d));
        memset(known, false, sizeof(known));
        BFS(i);
        int sum = 0;
        for(int i=1; i<=N; i++)
        sum += d[i];
        double ave = (double)sum / (N-1);
        int t = 100 * ave;
        Min = min(Min, t);
    }
    printf("%d\n", Min);
    return 0;
} 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值