PAT甲级真题 1048 Find Coins (25分) C++实现 (找数组中两数和为某值,多种方法)

题目

Eva loves to collect coins from all over the universe, including some other planets like Mars. One day she visited a universal shopping mall which could accept all kinds of coins as payments. However, there was a special requirement of the payment: for each bill, she could only use exactly two coins to pay the exact amount. Since she has as many as 105 coins with her, she definitely needs your help. You are supposed to tell her, for any given amount of money, whether or not she can find two coins to pay for it.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive numbers: N (<=105, the total number of coins) and M(<=103, the amount of money Eva has to pay). The second line contains N face values of the coins, which are all positive numbers no more than 500. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the two face values V1 and V2 (separated by a space) such that V1 + V2 = M and V1 <= V2. If such a solution is not unique, output the one with the smallest V1. If there is no solution, output “No Solution” instead.

Sample Input 1:

8 15
1 2 8 7 2 4 11 15

Sample Output 1:

4 11

Sample Input 2:

7 14
1 8 7 2 4 11 15

Sample Output 2:

No Solution

思路

这道题很容易通过,有多种方法。

排序+二分查找

一开始想到的是排序后二分查找(顺序遍历,在其后面找等于M - a[i]的数),复杂度为O(nlogn)。具体是排序用时nlogn,二分查找用时log(n-1) + log(n-2) + log(n-3)……+ 1 = log(n-1)! = O(nlogn)。

用到了STL库函数,algorithm.h中定义的binary_search

bool binary_search (ForwardIterator first, ForwardIterator last, const T& val);

返回值表示是否找到了元素。

排序+双指针

也可以排序后用双指针i、j分别指向头尾,若和大于M则左移最j,若和小于M则右移i;若二者相遇还没找到和等于M的,则无解。复杂度为nlogn + n,量级一样但具体复杂度低了。

参考:PAT-A 1048 Find Coins (25 分)

Hash

柳神用了复杂度O(n)的方法,用空间换时间。考虑到数组中每个元素值都不超过500,可以以数值为索引,记录元素个数。这样查找就能直接完成。

参考:1048. Find Coins (25)-PAT甲级真题(Hash散列)

代码

二分查找版:

#include <iostream>
#include <vector>
#include <algorithm>
using namespace std;

int main(){
    int n, m;
    cin >> n >> m;
    vector<int> coin(n);
    for (int i=0; i<n; i++){
        cin >> coin[i];
    }
    sort(coin.begin(), coin.end());
    for (int i=0; i<n-1; i++){
        if (binary_search(coin.begin()+i+1, coin.end(), m-coin[i])){
            cout << coin[i] << " " << m - coin[i] << endl;
            return 0;
        }
    }
    cout << "No Solution" << endl;
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值