poj 1679 The Unique MST

点击打开链接

The Unique MST
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 31493 Accepted: 11369

Description

Given a connected undirected graph, tell if its minimum spanning tree is unique. 

Definition 1 (Spanning Tree): Consider a connected, undirected graph G = (V, E). A spanning tree of G is a subgraph of G, say T = (V', E'), with the following properties: 
1. V' = V. 
2. T is connected and acyclic. 

Definition 2 (Minimum Spanning Tree): Consider an edge-weighted, connected, undirected graph G = (V, E). The minimum spanning tree T = (V, E') of G is the spanning tree that has the smallest total cost. The total cost of T means the sum of the weights on all the edges in E'. 

Input

The first line contains a single integer t (1 <= t <= 20), the number of test cases. Each case represents a graph. It begins with a line containing two integers n and m (1 <= n <= 100), the number of nodes and edges. Each of the following m lines contains a triple (xi, yi, wi), indicating that xi and yi are connected by an edge with weight = wi. For any two nodes, there is at most one edge connecting them.

Output

For each input, if the MST is unique, print the total cost of it, or otherwise print the string 'Not Unique!'.

Sample Input

2
3 3
1 2 1
2 3 2
3 1 3
4 4
1 2 2
2 3 2
3 4 2
4 1 2

Sample Output

3
Not Unique!
判断是否只有一个最小生成树,如果只有一个,输出最小权值,如果不是,输出Not Unique   。

这是我第一次做这种题,看了一个博客,好不容易想明白的,先找出最小生成树,接下来遍历一遍,当去掉一条线,判断其他的能不能再组成权值相等的最小生成树,如果能,那就说明这不是唯一。

#include<iostream>
#include<cstdio>
#include<algorithm>
using namespace std;
struct node
{
    int u,v,w;
    int eq,used,del;
} edg[10010];
int n,m,cnt,fa[10010];
bool flag;
bool comp(node x,node y)
{
    return x.w<y.w;
}
void init()//初始化
{
    for(int i=0; i<=10000; i++)
        fa[i]=i;
}
int find(int x)//查找
{
    return x==fa[x]?x:fa[x]=find(fa[x]);
}
void Union(int x,int y)//并查集
{
    x=find(x);
    y=find(y);
    fa[y]=x;
}
int Kruskal()//最小生成树
{
    init();
    int sum=0,num=0;
    for(int i=0; i<m; i++)
    {
        if(edg[i].del==1)
            continue;
        int u=edg[i].u,v=edg[i].v,w=edg[i].w;
        if(find(u)!=find(v))
        {
            if(!flag)
                edg[i].used=1;
            Union(u,v);
            num++;
            sum+=w;
        }
        if(num>=n-1)
            break;
    }
    return sum;
}
int main()
{
    int t;
    cin>>t;
    while(t--)
    {
        cnt=0;
        cin>>n>>m;
        for(int i=0; i<m; i++)
        {
            cin>>edg[i].u>>edg[i].v>>edg[i].w;
            edg[i].eq=0;
            edg[i].used=0;
            edg[i].del=0;
        }
        for(int i=0; i<m; i++) //找出相同权值的点
        {
            for(int j=0; j<m; j++)
            {
                if(i==j)
                    continue;
                if(edg[i].w==edg[j].w)
                    edg[i].eq=1;
            }
        }
        flag=false;
        sort(edg,edg+m,comp);
        cnt=Kruskal();
        flag=true;
        bool gg=false;
        for(int i=0; i<m; i++) //遍历判断
        {
            if(edg[i].used==1&&edg[i].eq==1)
            {
                edg[i].del=1;
                int s=Kruskal();
                if(s==cnt)
                {
                    gg=true;
                    printf("Not Unique!\n");
                    break;
                }
            }
            edg[i].del=0;
        }
        if(!gg)
            printf("%d\n",cnt);
    }
    return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值