哈希运用

               
H - H
Time Limit:4000MS     Memory Limit:65536KB     64bit IO Format:%I64d & %I64u

Description

Given a permutation P of 1 to N, YY wants to know whether there exists such three elements P[i   1], P[i   2], P[i   3] that  
P[i   1]-P[i   2]=P[i   2]-P[i   3], 1<=i   1<i   2<i   3<=N.
 

Input

The first line is T(T<=60), representing the total test cases.  
Each test case comes two lines, the former one is N, 3<=N<=10000, the latter is a permutation of 1 to N.
 

Output

For each test case, just output 'Y' if such i   1, i   2, i   3  can be found, else 'N'.
 

Sample Input

       
       
2 3 1 3 2 4 3 2 4 1
 

Sample Output

       
       
N Y
 

#include <stdio.h>
#include <string.h>
int hs[100000];
int ch[100000];         //再次强调数组大小问题,要开足
int main()
{
    int T,n,i,j,flag;
    scanf("%d",&T);
    while(T--)
    {
        memset(hs,0,sizeof(hs));
        flag=0;
        scanf("%d",&n);
        for(i=0; i<n; i++)
        {
            scanf("%d",&ch[i]);
            hs[ch[i]]=i;
        }
        for(i=0; i<n-2; i++)
            for(j=i+2; j<n; j++)
            {
                int a=ch[i]+ch[j];
                if(a%2!=0)                     //注意偶数的判断,如果是奇数就直接略过
                    continue;
                else
                {
                    if(hs[a/2]>i&&hs[a/2]<j)
                    {
                        flag=1;
                        break;
                    }
                }
            }
        if(flag)
            printf("Y\n");
        else
            printf("N\n");
    }
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
好的,下面是使用 Java 和 Hutool 工具库实现哈希算法存储用户密码的示例代码: ```java import cn.hutool.crypto.digest.DigestUtil; import cn.hutool.crypto.digest.DigestAlgorithm; public class PasswordUtil { // 生成随机盐值 private static String generateSalt() { return RandomUtil.randomString(16); } // 对密码进行哈希加密 public static String hashPassword(String password) { // 生成随机盐值 String salt = generateSalt(); // 将盐值和密码拼接起来,并进行哈希加密 String hashedPassword = DigestUtil.sha256Hex(salt + password); // 返回哈希加密后的密码和盐值,使用“:”分隔 return hashedPassword + ":" + salt; } // 比对密码是否正确 public static boolean verifyPassword(String password, String hashedPassword) { // 从哈希密码中分离出盐值和哈希密码 String[] parts = hashedPassword.split(":"); if (parts.length != 2) { return false; } String salt = parts[1]; String expectedHashedPassword = parts[0]; // 将盐值和密码拼接起来,并进行哈希加密 String inputHashedPassword = DigestUtil.sha256Hex(salt + password); // 比对哈希加密后的密码和数据库中存储的密码是否相等 return inputHashedPassword.equals(expectedHashedPassword); } } ``` 在上面的示例代码中,使用 Hutool 工具库的 `DigestUtil.sha256Hex` 方法对密码进行哈希加密,使用 `RandomUtil.randomString` 方法生成随机盐值。对于存储在数据库中的哈希密码,使用“:”符号将哈希密码和盐值分隔开,方便后续进行比对。 需要注意的是,在进行哈希加密时需要使用一个安全性较高的哈希算法,并且密钥长度要足够长,同时也要进行适当的盐值处理等安全措施。

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值