Layout

     
D - D
Time Limit:1000MS     Memory Limit:65536KB     64bit IO Format:%I64d & %I64u

Description

Like everyone else, cows like to stand close to their friends when queuing for feed. FJ has N (2 <= N <= 1,000) cows numbered 1..N standing along a straight line waiting for feed. The cows are standing in the same order as they are numbered, and since they can be rather pushy, it is possible that two or more cows can line up at exactly the same location (that is, if we think of each cow as being located at some coordinate on a number line, then it is possible for two or more cows to share the same coordinate). 

Some cows like each other and want to be within a certain distance of each other in line. Some really dislike each other and want to be separated by at least a certain distance. A list of ML (1 <= ML <= 10,000) constraints describes which cows like each other and the maximum distance by which they may be separated; a subsequent list of MD constraints (1 <= MD <= 10,000) tells which cows dislike each other and the minimum distance by which they must be separated. 

Your job is to compute, if possible, the maximum possible distance between cow 1 and cow N that satisfies the distance constraints.

Input

Line 1: Three space-separated integers: N, ML, and MD. 

Lines 2..ML+1: Each line contains three space-separated positive integers: A, B, and D, with 1 <= A < B <= N. Cows A and B must be at most D (1 <= D <= 1,000,000) apart. 

Lines ML+2..ML+MD+1: Each line contains three space-separated positive integers: A, B, and D, with 1 <= A < B <= N. Cows A and B must be at least D (1 <= D <= 1,000,000) apart.

Output

Line 1: A single integer. If no line-up is possible, output -1. If cows 1 and N can be arbitrarily far apart, output -2. Otherwise output the greatest possible distance between cows 1 and N.

Sample Input

4 2 1
1 3 10
2 4 20
2 3 3

Sample Output

27

Hint

Explanation of the sample: 

There are 4 cows. Cows #1 and #3 must be no more than 10 units apart, cows #2 and #4 must be no more than 20 units apart, and cows #2 and #3 dislike each other and must be no fewer than 3 units apart. 

The best layout, in terms of coordinates on a number line, is to put cow #1 at 0, cow #2 at 7, cow #3 at 10, and cow #4 at 27.
这是个差分约束的题,这个题的大意就是:总共有n个牛,让 这n个牛排成一队,有的牛之间不相互喜欢就想离得远一点,但有个上限,有的牛之间比较喜欢在一起,同样有个下限,计算这n个牛的最短距离。
#include <stdio.h>
#include <string.h>
#define maxnum 30000
#define maxint 0x3f3f3f3f
int dis[maxnum];
int count,n;
struct node
{
    int u,v,w;
} edge[maxnum];
void build(int u,int v,int w)           
{
    count++;
    edge[count].u=u;
    edge[count].v=v;
    edge[count].w=w;
}
void  relax(int u,int v,int w)         //松弛
{
    if(dis[v]>dis[u]+w)
        dis[v]=dis[u]+w;
}
int BF()
{
    int i,j;
    for(i=0; i<n-1; i++)             //因为有n个点,所以最多循环n-1次
        for(j=1; j<=count; j++)
            relax(edge[j].u,edge[j].v,edge[j].w);
    for(i=1; i<=count; i++)          //判断有无负环
    {
        if(dis[edge[i].v]>dis[edge[i].u]+edge[i].w)
        {
            return 0;
        }
    }
    return 1;
}
int main()
{
    int ML,MD,i,x,y,z;
    while(~scanf("%d%d%d",&n,&ML,&MD))
    {
        count=0;
        memset(dis,maxint,sizeof(dis));
        dis[1]=0;
        for(i=1; i<=ML; i++)
        {
            scanf("%d%d%d",&x,&y,&z);
            build(x,y,z);               //建立有向图,z值代表的是最大权值
        }
        for(i=1; i<=MD; i++)            //此种情况下,让x与y反过来,那么它俩之间就是小于等于一个数
        {
            scanf("%d%d%d",&x,&y,&z);
            build(y,x,-z);
        }
        if(BF()==0)                      //因为建的图有可能有负权值也有可能有负环,所以用的是贝尔曼-福特算法,如果有负环则输出-1
            printf("-1\n");
        else if(dis[n]>=maxint)          //如果距离太大就输出-2
            printf("-2\n");
        else
            printf("%d\n",dis[n]);
    }
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值