Wormholes(POJ--3259

Description

While exploring his many farms, Farmer John has discovered a number of amazing wormholes. A wormhole is very peculiar because it is a one-way path that delivers you to its destination at a time that is BEFORE you entered the wormhole! Each of FJ's farms comprises N (1 ≤ N ≤ 500) fields conveniently numbered 1..NM (1 ≤ M ≤ 2500) paths, and W (1 ≤ W ≤ 200) wormholes.

As FJ is an avid time-traveling fan, he wants to do the following: start at some field, travel through some paths and wormholes, and return to the starting field a time before his initial departure. Perhaps he will be able to meet himself :) .

To help FJ find out whether this is possible or not, he will supply you with complete maps to F (1 ≤ F ≤ 5) of his farms. No paths will take longer than 10,000 seconds to travel and no wormhole can bring FJ back in time by more than 10,000 seconds.

题意:输入T,表示John家有T块田,每组数据输入n,m,k,分别表示有n小块编号从1到n,有m条路,有k条时光隧道,

接下来有m行,每行输入s,e,t,表示从s号田到e号田需要花费t秒时间,接下来有k行,每行输入s,e,t,表示从s号田到e号田能退回t秒之前。问John通过时光隧道回到他离开最开始的那块田之前,如果能就输出YES,否则输出NO。

思路:其实就是判断John走的路是否存在负环。

Input

Line 1: A single integer, FF farm descriptions follow. 
Line 1 of each farm: Three space-separated integers respectively: NM, and W 
Lines 2..M+1 of each farm: Three space-separated numbers (SET) that describe, respectively: a bidirectional path between S and E that requires T seconds to traverse. Two fields might be connected by more than one path. 
Lines M+2..M+W+1 of each farm: Three space-separated numbers (SET) that describe, respectively: A one way path from S to E that also moves the traveler back T seconds.

Output

Lines 1..F: For each farm, output "YES" if FJ can achieve his goal, otherwise output "NO" (do not include the quotes).

Sample Input

2
3 3 1
1 2 2
1 3 4
2 3 1
3 1 3
3 2 1
1 2 3
2 3 4
3 1 8

Sample Output

NO
YES

Hint

For farm 1, FJ cannot travel back in time. 
For farm 2, FJ could travel back in time by the cycle 1->2->3->1, arriving back at his starting location 1 second before he leaves. He could start from anywhere on the cycle to accomplish this.

#include <cstdio>
#include <cstring>
#include <queue>
using namespace std;
typedef struct Edge
{
    int v,w;
} Edge;
Edge eg;
int dis[3000],in[3000],n;
bool vis[3000];
vector<Edge>vct[3000];
bool SPFA()
{
    int u,v;
    memset(dis,-1,sizeof(dis));       //记录到该节点的距离
    memset(in,0,sizeof(in));
    memset(vis,0,sizeof(vis));        
    queue<int>q;
    dis[1]=0;
    q.push(1);
    while(!q.empty())
    {
        u=q.front();
        q.pop();
        vis[u]=0;
        for(int i=0; i<vct[u].size(); i++)
        {
            v=vct[u][i].v;
            if(dis[v]==-1||dis[v]>dis[u]+vct[u][i].w)
            {
                dis[v]=dis[u]+vct[u][i].w;     //更新源点到当前节点的距离
                if(!vis[v])
                {
                    in[v]++;
                    if(in[v]==n)
                        return 1;
                    vis[v]=1;
                    q.push(v);
                }
            }
        }
    }
    return 0;
}
int main()
{
//freopen("aa.text","r",stdin);
    int T,m,k,u,v,w;
    scanf("%d",&T);
    while(T--)
    {
        memset(vct,0,sizeof(vct));       //一定要记得清空啊2333
        scanf("%d %d %d",&n,&m,&k);
        for(int i=0; i<m; i++)
        {
            scanf("%d %d %d",&u,&v,&eg.w);
            eg.v=v;
            vct[u].push_back(eg);
            eg.v=u;
            vct[v].push_back(eg);
        }
        for(int i=0; i<k; i++)
        {
            scanf("%d %d %d",&u,&v,&w);
            eg.v=v;
            eg.w=-w;                                 //因为这是退回t时间之前,所以该边的值为负值
            vct[u].push_back(eg);
        }
        if(SPFA())
            printf("YES\n");
        else
            printf("NO\n");
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值