Frogger(POJ--2253

Description

Freddy Frog is sitting on a stone in the middle of a lake. Suddenly he notices Fiona Frog who is sitting on another stone. He plans to visit her, but since the water is dirty and full of tourists' sunscreen, he wants to avoid swimming and instead reach her by jumping. 
Unfortunately Fiona's stone is out of his jump range. Therefore Freddy considers to use other stones as intermediate stops and reach her by a sequence of several small jumps. 
To execute a given sequence of jumps, a frog's jump range obviously must be at least as long as the longest jump occuring in the sequence. 
The frog distance (humans also call it minimax distance) between two stones therefore is defined as the minimum necessary jump range over all possible paths between the two stones. 

You are given the coordinates of Freddy's stone, Fiona's stone and all other stones in the lake. Your job is to compute the frog distance between Freddy's and Fiona's stone. 

Input

The input will contain one or more test cases. The first line of each test case will contain the number of stones n (2<=n<=200). The next n lines each contain two integers xi,yi (0 <= xi,yi <= 1000) representing the coordinates of stone #i. Stone #1 is Freddy's stone, stone #2 is Fiona's stone, the other n-2 stones are unoccupied. There's a blank line following each test case. Input is terminated by a value of zero (0) for n.

Output

For each test case, print a line saying "Scenario #x" and a line saying "Frog Distance = y" where x is replaced by the test case number (they are numbered from 1) and y is replaced by the appropriate real number, printed to three decimals. Put a blank line after each test case, even after the last one.

Sample Input

2
0 0
3 4

3
17 4
19 4
18 5

0

Sample Output

Scenario #1
Frog Distance = 5.000

Scenario #2
Frog Distance = 1.414

floyd做法   504K,157MS,1161B:

<span style="font-size:18px;">#include <cstdio>
#include <algorithm>
#include <cmath>
#include <cstring>
#define INF 0x3f3f3f3f
#define esp 1e-9
using namespace std;
double map[205][205];
bool vis[205];
int n;
struct node
{
    int x,y;
} st[205];
double dis(int a,int b)               //求两点间的距离,返回值double型是函数则sqrt()函数内的参数值也应该是double型
{
    return sqrt((st[a].x-st[b].x)*(st[a].x-st[b].x)*1.0+(st[a].y-st[b].y)*(st[a].y-st[b].y)*1.0);
}
int dcmp(double x)                   //判断double类型数值与0的比较
{
    return x<-esp?-1:x>esp;
}
void flo()                                    //对于floyd做法,其根本就是暴力所有的点,不断更新两点间的距离
{
    for(int k=1; k<=n; k++)         //循环顺序不能错,最外层是三点间的中间点,第二层是三点间的最前点,第三层是三点间的最后点
        for(int i=1; i<=n; i++)
            for(int j=1; j<=n; j++)
            {
                if(dcmp(map[i][j]-map[i][k])>0&&dcmp(map[i][j]-map[k][j])>0)
                    map[i][j]=map[j][i]=max(map[i][k],map[k][j]);   //寻找从i点到j点的最短路中的最长路径
            }
}
int main()
{
    int cnt=0;
    while(~scanf("%d",&n))
    {
        if(n==0)
            break;
        memset(map,0,sizeof(map));
        cnt++;
        for(int i=1; i<=n; i++)
        {
            scanf("%d %d",&st[i].x,&st[i].y);
            for(int j=1; j<=i; j++)
            {
                map[i][j]=map[j][i]=dis(i,j);
            }
        }
        flo();
        printf("Scenario #%d\nFrog Distance = %.3lf\n\n",cnt,map[1][2]);
    }
    return 0;
}</span>

dijkstra做法  500K,0MS,1404B:

<span style="font-size:18px;">#include <cstdio>
#include <algorithm>
#include <cstring>
#include <cmath>
#define esp 1e-9
using namespace std;
double map[205][205];
double ds[205];
bool vis[205];
int n;
struct node
{
    int x,y;
} st[205];
double dis(int a,int b)                       //求两点间的距离,返回值是double型则sqrt()函数里的参数也应该是double型
{
    return sqrt((st[a].x-st[b].x)*(st[a].x-st[b].x)*1.0+(st[a].y-st[b].y)*(st[a].y-st[b].y)*1.0);
}
int dcmp(double x)                           //判断与0的大小
{
   return x<-esp?-1:x>esp;
}
double dijkstra()
{
    memset(vis,0,sizeof(vis));
    double w;
    int k;
    for(int i=1; i<n; i++)
        ds[i]=1111111;
    ds[0]=0;
    for(int i=0; i<n; i++)
    {
        w=1111111;
        k=-1;
        for(int j=0; j<n; j++)
        {
            if(!vis[j]&&w>ds[j])
            {
                w=ds[j];
                k=j;
            }
        }
        if(k==1)                                      //如果最短路就是终点,则直接跳出
            return ds[1];
        vis[k]=1;
        for(int j=0; j<n; j++)
        {
            if(!vis[j]&&dcmp(ds[j]-ds[k])>0&&dcmp(ds[j]-map[k][j])>0)
            {
                ds[j]=max(ds[k],map[k][j]);      //保存最短路中的最大路径
            }
        }
    }
    return ds[1];
}
int main()
{
    int cnt=0;
    while(~scanf("%d",&n))
    {
        if(n==0)
            break;
        for(int i=0; i<n; i++)
        {
            scanf("%d %d",&st[i].x,&st[i].y);
            for(int j=0; j<=i; j++)
                map[i][j]=map[j][i]=dis(i,j);
        }
        printf("Scenario #%d\nFrog Distance = %.3lf\n\n",++cnt,dijkstra());
    }
    return 0;
}</span>

SPFA做法  512K,0MS,1370B:

<span style="font-size:18px;">#include <cstdio>
#include <cmath>
#include <algorithm>
#include <cstring>
#include <queue>
#define esp 1e-9
using namespace std;
struct node
{
    int x,y;
} st[205];
double map[205][205];
double ds[205];
bool vis[205];
int n;
double dis(int a,int b)
{
    return sqrt((st[a].x-st[b].x)*(st[a].x-st[b].x)*1.0+(st[a].y-st[b].y)*(st[a].y-st[b].y)*1.0);
}
int dcmp(double x)
{
    return x<-esp?-1:x>esp;
}
double SPFA()               //对于SPFA做法来说,主要引入了队列
{
    int u;
    memset(vis,0,sizeof(vis));
    for(int i=1; i<n; i++)
        ds[i]=1111111;
    ds[0]=0;
    queue<int>q;
    q.push(0);
    while(!q.empty())
    {
        u=q.front();
        q.pop();
        vis[u]=0;
        for(int i=0; i<n; i++)
        {
            if(dcmp(ds[i]-ds[u])>0&&dcmp(ds[i]-map[u][i])>0)
            {
                ds[i]=max(ds[u],map[u][i]);
                if(!vis[i])
                {
                    vis[i]=1;
                    q.push(i);
                }
            }
        }
    }
    return ds[1];
}
int main()
{
    int cnt=0;
    while(~scanf("%d",&n))
    {
    if(n==0)
    break;
        memset(map,0,sizeof(map));
        for(int i=0; i<n; i++)
        {
            scanf("%d %d",&st[i].x,&st[i].y);
            for(int j=0; j<=i; j++)
                map[i][j]=map[j][i]=dis(i,j);
        }
        printf("Scenario #%d\nFrog Distance = %.3lf\n\n",++cnt,SPFA());
    }
    return 0;
}</span><strong style="font-size: 18pt;">
</strong>


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值