Balance(POJ--1837

Description

Gigel has a strange "balance" and he wants to poise it. Actually, the device is different from any other ordinary balance. 
It orders two arms of negligible weight and each arm's length is 15. Some hooks are attached to these arms and Gigel wants to hang up some weights from his collection of G weights (1 <= G <= 20) knowing that these weights have distinct values in the range 1..25. Gigel may droop any weight of any hook but he is forced to use all the weights. 
Finally, Gigel managed to balance the device using the experience he gained at the National Olympiad in Informatics. Now he would like to know in how many ways the device can be balanced. 

Knowing the repartition of the hooks and the set of the weights write a program that calculates the number of possibilities to balance the device. 
It is guaranteed that will exist at least one solution for each test case at the evaluation. 

Input

The input has the following structure: 
• the first line contains the number C (2 <= C <= 20) and the number G (2 <= G <= 20); 
• the next line contains C integer numbers (these numbers are also distinct and sorted in ascending order) in the range -15..15 representing the repartition of the hooks; each number represents the position relative to the center of the balance on the X axis (when no weights are attached the device is balanced and lined up to the X axis; the absolute value of the distances represents the distance between the hook and the balance center and the sign of the numbers determines the arm of the balance to which the hook is attached: '-' for the left arm and '+' for the right arm); 
• on the next line there are G natural, distinct and sorted in ascending order numbers in the range 1..25 representing the weights' values. 

Output

The output contains the number M representing the number of possibilities to poise the balance.
题意:给你c个挂钩的位置和g个砝码,问使天平平衡的方法种数。
思路:用数组dp[i][j]表示此时挂i个砝码天平状态为j的情况,如果j<0则表示天平倾斜于左,如果j=0则表示天平平衡,如果j>0则表示天平倾斜于右。天平状态j的最大是20*15*25=7500,再加上为了防止数组坐标下标为负数,则整个状态右移7500,即状态最大为15000,天平平衡点为7500。

Sample Input

2 4	
-2 3 
3 4 5 8

Sample Output

2

#include <cstdio>
#include <cstring>
#include <algorithm>
#include <iostream>
#include <queue>
#define MAX 0x3f3f3f3f
using namespace std;
int c[50],g[50],C,G;        //c数组用来记录挂钩位置,g数组用来记录砝码重量
int dp[50][15005];        //记录当时挂i个砝码的状态
int main()
{
    //freopen("lalala.text","r",stdin);
    while(~scanf("%d %d",&C,&G))
    {
        for(int i=1; i<=C; i++)
            scanf("%d",&c[i]);
        for(int i=1; i<=G; i++)
            scanf("%d",&g[i]);
        memset(dp,0,sizeof(dp));
        dp[0][7500]=1;
        for(int i=1; i<=G; i++)         //枚举当前砝码
            for(int j=0; j<=15000; j++)    //枚举状态
                if(dp[i-1][j])
                    for(int k=1; k<=C; k++)    //枚举挂钩位置
                        dp[i][j+g[i]*c[k]]+=dp[i-1][j];
        printf("%d\n",dp[G][7500]);
    }
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值