The Cow Lexicon(POJ--3267

Description

Few know that the cows have their own dictionary with W (1 ≤ W ≤ 600) words, each containing no more 25 of the characters 'a'..'z'. Their cowmunication system, based on mooing, is not very accurate; sometimes they hear words that do not make any sense. For instance, Bessie once received a message that said "browndcodw". As it turns out, the intended message was "browncow" and the two letter "d"s were noise from other parts of the barnyard.

The cows want you to help them decipher a received message (also containing only characters in the range 'a'..'z') of length L (2 ≤ L ≤ 300) characters that is a bit garbled. In particular, they know that the message has some extra letters, and they want you to determine the smallest number of letters that must be removed to make the message a sequence of words from the dictionary.

Input

Line 1: Two space-separated integers, respectively: W and L 
Line 2: L characters (followed by a newline, of course): the received message 
Lines 3..W+2: The cows' dictionary, one word per line

Output

Line 1: a single integer that is the smallest number of characters that need to be removed to make the message a sequence of dictionary words.
题意:输入w和l分别代表字典里单词的个数和要匹配的单词st的长度。接下来输入字典里的单词。求用字典里的单词匹配单词st,单词st里至少有几个多余的字母。
思路:从单词st的最后一个字母往前枚举,只要找到当前字母与字典里单词的首字母相同则说明当前字典里的单词可能是单词st的一部分,然后去匹配看能不能全部匹配完,如果能就看一下多余的字母有几个,如果不能就接着枚举字典里的下一个单词。具体怎么操作请看代码。

Sample Input

6 10
browndcodw
cow
milk
white
black
brown
farmer

Sample Output

2

#include <cstdio>
#include <cstring>
#include <algorithm>
#include <iostream>
#include <queue>
#define INF 0x3f3f3f3f
using namespace std;
char  dic[800][30];              //存储字典里的单词
int dp[350];                
char st[350];                        //要匹配的单词
int main()
{
    //freopen("lalala.text","r",stdin);
    int w,l,p,q,cnt;
    while(~scanf("%d %d",&w,&l))
    {
        scanf("%s",st);
        for(int i=0; i<w; i++)
            scanf("%s",dic[i]);
        dp[l]=0;                   //从单词st的最后一个字母开始,则dp[l]=0
        for(int i=l-1; i>=0; i--)
        {
            dp[i]=dp[i+1]+1;      //假设当前字母不与字典里任何单词的首字母相同,则当前字母就是多余的字母,则dp[i]就等于后一个字母+1
            for(int j=0; j<w; j++)     //开始枚举字典里的单词
            {
                if(dic[j][0]==st[i])         //如果当前字母与字典里某一单词的首字母相同则看此单词是否是单词st的一部分
                {
                    int len=strlen(dic[j]);
                    p=0;
                    q=i;
                    cnt=0;
                    while(p<len&&q<l)
                    {
                        if(dic[j][p]==st[q])
                        {
                            p++;
                            q++;
                        }
                        else
                        {
                            q++;
                            cnt++;
                        }
                    }
                    if(p==len)    //如果是的话就更新单词st当前字母的多余字母数即dp[i]
                    {
                        dp[i]=min(dp[i],dp[q]+cnt);
                    }
                }
            }
        }
        printf("%d\n",dp[0]);
    }
    return 0;
}<strong>
</strong>


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值