1146:统计立方数

1146:统计立方数


Description


有一堆立方数,统计其中有多少立方数。


Input


输入数据有一些正整数,其每个数都小于2^32。若该数为0,则应结束统计。


Output


输出所统计的立方数个数。


Sample Input


1 3 5 7 9 11 15 17 19 21 23 25 27 0


Sample Output


2


#include<iostream>
#include<stdio.h>
#include<string.h>
#include<math.h>
using namespace std;
int main()
{
    int a;
    int i,count=0;
    while(1==scanf("%d",&a)!=EOF&&a)
    {
 
       for(i=1;i<=sqrt(a);i++)
    {
 
            if(a==i*i*i)
                count++;
        }
    }
  cout<<count;
   return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值