Hdu-Connect the Cities

题目名称:Connect the Cities

题目链接:Connect the Cities

Problem Description

In 2100, since the sea level rise, most of the cities disappear. Though some survived cities are still connected with others, but most of them become disconnected. The government wants to build some roads to connect all of these cities again, but they don’t want to take too much money.

Input

The first line contains the number of test cases.
Each test case starts with three integers: n, m and k. n (3 <= n <=500) stands for the number of survived cities, m (0 <= m <= 25000) stands for the number of roads you can choose to connect the cities and k (0 <= k <= 100) stands for the number of still connected cities.
To make it easy, the cities are signed from 1 to n.
Then follow m lines, each contains three integers p, q and c (0 <= c <= 1000), means it takes c to connect p and q.
Then follow k lines, each line starts with an integer t (2 <= t <= n) stands for the number of this connected cities. Then t integers follow stands for the id of these cities.

Output

For each case, output the least money you need to take, if it’s impossible, just output -1.

Sample Input

1
6 4 3
1 4 2
2 6 1
2 3 5
3 4 33
2 1 2
2 1 3
3 4 5 6

Sample Output

1

解题思路

简单的并查集+边的判断+最小生成树问题,在使用构建最小生成数时注意对边的统计,因为在最后 k 行数据中并不能保证所有的城市都是孤立的,所以使用并查集统计统计没有公共节点的城市,他们之间的边才算有效,最后通过根据 边+1=城市个数来判断是否符合条件即可

完整代码

#include<iostream>
#include<algorithm>
using namespace std;
#define N 25100

struct Node{
	int from,to,cost;
	Node(int from=0,int to=0,int cost=0):from(from),to(to),cost(cost){}
}node[N];
int t,n,m,k,q,p,c;
int f[N];   //父节点
int tot;   //边的个数

bool cmp(Node a,Node b){
	return a.cost<b.cost;
}

int find(int x){
	return x==f[x]?x:f[x]=find(f[x]);
}

void unions(int a,int b){   //合并
	a=find(a);
	b=find(b);
	if(a!=b){
		tot++;
		f[b]=a;
	}
}

int main()
{
	ios::sync_with_stdio(false);   //防止超时
	cin>>t;
	while(t--){
		cin>>n>>m>>k;
		for(int i=1;i<=n;i++) f[i]=i;
		for(int i=0;i<m;i++){
			cin>>q>>p>>c;
			node[i]=Node(q,p,c);
		}
		sort(node,node+m,cmp);

		tot=0;
		for(int i=0;i<k;i++){
			cin>>q>>p;
			q--;
			while(q--){
				cin>>c;
				unions(p,c); 
			}
			
		}
		int sum=0;
		for(int i=0;i<m&&tot<n;i++){
			int fa=find(node[i].from);
			int fb=find(node[i].to);
			if(fa!=fb){
				f[fb]=fa;
				tot++;
				sum+=node[i].cost;
			}
		}
		if(tot<n-1){
			cout<<"-1\n";
		}else{
			cout<<sum<<endl;
		}
	
	}
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值