poj2376 Cleaning Shifts(dp,线段树优化)

25 篇文章 0 订阅

Cleaning Shifts

Description
Farmer John is assigning some of his N (1 <= N <= 25,000) cows to do some cleaning chores around the barn. He always wants to have one cow working on cleaning things up and has divided the day into T shifts (1 <= T <= 1,000,000), the first being shift 1 and the last being shift T.

Each cow is only available at some interval of times during the day for work on cleaning. Any cow that is selected for cleaning duty will work for the entirety of her interval.

Your job is to help Farmer John assign some cows to shifts so that (i) every shift has at least one cow assigned to it, and (ii) as few cows as possible are involved in cleaning. If it is not possible to assign a cow to each shift, print -1

Input
* Line 1: Two space-separated integers: N and T
* Lines 2..N+1: Each line contains the start and end times of the interval during which a cow can work. A cow starts work at the start time and finishes after the end time.
*
Output
* Line 1: The minimum number of cows Farmer John needs to hire or -1 if it is not possible to assign a cow to each shift.
*
Sample Input
3 10
1 7
3 6
6 10

Sample Output
2

Hint
This problem has huge input data,use scanf() instead of cin to read data to avoid time limit exceed.

INPUT DETAILS:
There are 3 cows and 10 shifts. Cow #1 can work shifts 1..7, cow #2 can work shifts 3..6, and cow #3 can work shifts 6..10.

OUTPUT DETAILS:
By selecting cows #1 and #3, all shifts are covered. There is no way to cover all the shifts using fewer than 2 cows.

题意:一个区间长度为T,给出N个区间,求至少需要多少个区间能完全覆盖此区间。

分析:dp方程很容易想到,在此不赘述,设f[i]表示覆盖[L,i]最少需要的区间数,f[i]=min(f[x])+1,a[i]-1<=x<=b[i]。直接枚举显然超时,需要用线段树维护区间[a[i]-1,b[i]]的最小值,方便查询。

代码

#include <cstdio>
#include <algorithm>
#include <string>
#include <cstring>
#define N 1000005
#define inf 1e9
using namespace std;

struct tree
{
    int l, r, min;
}tr[N * 4],a[N];
int n,m,f[N],x;

int cmp(tree x, tree y){return x.r < y.r;}

void build(int p)
{
    tr[p].min = inf;
    if (tr[p].l == tr[p].r) 
    {
        if (tr[p].l == 0) tr[p].min = 0;
        return;
    }
    int mid = (tr[p].l + tr[p].r) / 2;
    tr[p * 2].l = tr[p].l;
    tr[p * 2].r = mid;
    tr[p * 2 + 1].l = mid + 1;
    tr[p * 2 + 1].r = tr[p].r;
    build(p * 2);
    build(p * 2 + 1);
    tr[p].min = min(tr[p * 2].min, tr[p * 2 + 1].min);
}

void find(int p, int L, int R)
{
    if (tr[p].l == L && tr[p].r == R)
    {
        x = min(x, tr[p].min);
        return;
    }
    int mid = (tr[p].l + tr[p].r) / 2;
    if (R <= mid) find(p * 2, L, R);
        else if (L > mid) find(p * 2 + 1, L, R);
            else find(p * 2, L, mid), find(p * 2 + 1, mid + 1, R);
}

void ins(int p, int pos, int val)
{
    if (tr[p].l == tr[p].r)
    {
        tr[p].min = min(tr[p].min, val);
        return;
    }
    int mid = (tr[p].l + tr[p].r) / 2;
    if (pos <= mid) ins(p * 2, pos, val);
        else ins(p * 2 + 1, pos, val);
    tr[p].min = min(tr[p * 2].min, tr[p * 2 + 1].min);
}

int main()
{
    scanf("%d%d", &n, &m);
    for (int i = 1; i <= n; i++)
        scanf("%d%d", &a[i].l, &a[i].r);
    sort(a + 1, a + n + 1, cmp);
    tr[1].l = 0;
    tr[1].r = m;
    build(1);
    for (int i = 1; i <= m; i++)
        f[i] = inf;
    for (int i = 1; i <= n; i++)
    {
        x = inf;
        if (a[i].l < 1) a[i].l = 1;
        if (a[i].r > m) a[i].r = n;
        find(1, a[i].l - 1, a[i].r);
        if (x + 1 < f[a[i].r]) 
        {
            f[a[i].r] = x + 1;
            ins(1, a[i].r, f[a[i].r]);
        }
    }
    if (f[m] < inf) printf("%d", f[m]);
        else printf("-1");
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值