Find Your Present

Find Your Present  
Time Limit(Common/Java):1000MS/3000MS     Memory Limit:1024KByte
Total Submit: 248            Accepted: 56
Description
In the new year party, everybody will get a "special present".Now it's your turn to get your special present, a lot of presents now putting on the desk, and only one of them will be yours.Each present has a card number on it, and your present's card number will be the one that different from all the others, and you can assume that only one number appear odd times.For example, there are 5 present, and their card numbers are 1, 2, 3, 2, 1.so your present will be the one with the card number of 3, because 3 is the number that different from all the others.
Input
The input file will consist of several cases. 
Each case will be presented by an integer n (1<=n<1000000, and n is odd) at first. Following that, n positive integers will be given in a line, all integers will smaller than 2^31. These numbers indicate the card numbers of the presents.n = 0 ends the input.
Output
For each case, output an integer in a line, which is the card number of your present.
Sample Input
5
1 1 3 2 2
3
1 2 1
0
Sample Output
3

2

这个题目你要理解2点

第一, 为什么要用 异或来算。

第二, 异或是怎么来算的。

 题目给的数据量特别大 如果之前试过用hash算的话,(既开一个1000000的数组来保存每一个数字出现得次数,然后扫描值为1的) 很可能会Memory Limit Exceeded 。  所以才想到了用异或。 异或:就是按位比较相同则为0不同则是1;
  比如   3^5,   3=011,5=101,两数按位异或后为110,即6。
     偶数次出现的异或结果为0 基数次结果为1
     然后  异或满足交换率。
再举一个例子。
   如 数据  1 2 3 2 1   
   先让result=0 
   那么可以看成是  result^1^2^3^2^1
        交换律     result^1^1^2^2^3
       很明显      1^1 和  2^2 都为 0 
       所以最后得    result^3 =0^3 =3(二进制 101)
代码:
#include<stdio.h>
int n;
int a;
int b;
int main()
{
    while(~scanf("%d",&n),n)
    {
        scanf("%d",&b);
        for(int c=1;c<n;c++)
        {
            scanf("%d",&a);
            b^=a;
        }
        printf("%d\n",b);
    }
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值