hdoj 1950(求最长顺序子序列)二分法的深度应用


   解决本题的关键就是理解题意,左边有一排纽扣,无序连接到第二排纽扣上,你的目的是让纽扣无交叉,把查找到的最长顺序子序列输出!




题目如下



Bridging signals

Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 1079    Accepted Submission(s): 704


Problem Description
'Oh no, they've done it again', cries the chief designer at the Waferland chip factory. Once more the routing designers have screwed up completely, making the signals on the chip connecting the ports of two functional blocks cross each other all over the place. At this late stage of the process, it is too
expensive to redo the routing. Instead, the engineers have to bridge the signals, using the third dimension, so that no two signals cross. However, bridging is a complicated operation, and thus it is desirable to bridge as few signals as possible. The call for a computer program that finds the maximum number of signals which may be connected on the silicon surface without rossing each other, is imminent. Bearing in mind that there may be housands of signal ports at the boundary of a functional block, the problem asks quite a lot of the programmer. Are you up to the task?

Figure 1. To the left: The two blocks' ports and their signal mapping (4,2,6,3,1,5). To the right: At most three signals may be routed on the silicon surface without crossing each other. The dashed signals must be bridged. 

A typical situation is schematically depicted in figure 1. The ports of the two functional blocks are numbered from 1 to p, from top to bottom. The signal mapping is described by a permutation of the numbers 1 to p in the form of a list of p unique numbers in the range 1 to p, in which the i:th number pecifies which port on the right side should be connected to the i:th port on the left side.
Two signals cross if and only if the straight lines connecting the two ports of each pair do.
 

Input
On the first line of the input, there is a single positive integer n, telling the number of test scenarios to follow. Each test scenario begins with a line containing a single positive integer p<40000, the number of ports on the two functional blocks. Then follow p lines, describing the signal mapping: On the i:th line is the port number of the block on the right side which should be connected to the i:th port of the block on the left side.
 

Output
For each test scenario, output one line containing the maximum number of signals which may be routed on the silicon surface without crossing each other.
 

Sample Input
      
      
4 6 4 2 6 3 1 5 10 2 3 4 5 6 7 8 9 10 1 8 8 7 6 5 4 3 2 1 9 5 8 9 2 3 1 7 4 6
 

Sample Output
      
      
3 9 1 4
 


想了半天才做出来的题,但总是re。。桑心    于是在学长的帮助下一点一点调试,终于找到了最简单的方法!

<span style="font-size:18px;">#include<stdio.h>
#define max 40005
int a[max],b[max];
 int  q( int left, int right, int s)
{
	 int  mid;
	while(right-left>=0)  // 注意理解这个条件判断可以判断所有可能的结果 
	{
		mid=(right+left)/2;
		if(b[mid]<s)
		left=mid+1;
		else
		right=mid-1;
	}
	return left;   //返回左边返回右边要看初始判断的(while(right-left>=0)) 
}
int main()
{
	 int  m,n,i;
	scanf("%d",&n);
	while(n--)
	{	 int j=1;
		scanf("%d",&m);
		for(i=0;i<m;i++)
		scanf("%d",&a[i]);
		b[0]=a[0];
		for(i=1;i<m;i++)
		{
			if(a[i]>b[j-1])
			b[j++]=a[i];
			else
			b[q(0,j-1,a[i])]=a[i];
		}
	printf("%d\n",j);
	}
	return 0;
}
	
  </span>


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值